题意
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 6392 | Accepted: 2080 |
Description
In order to prevent the worst-case scenario, Akira should distinguish the devilish from the divine. But how? They looked exactly alike and he could not distinguish one from the other solely by their appearances. He still had his last hope, however. The members of the divine tribe are truth-tellers, that is, they always tell the truth and those of the devilish tribe are liars, that is, they always tell a lie.
He asked some of them whether or not some are divine. They knew one another very much and always responded to him "faithfully" according to their individual natures (i.e., they always tell the truth or always a lie). He did not dare to ask any other forms of questions, since the legend says that a devilish member would curse a person forever when he did not like the question. He had another piece of useful informationf the legend tells the populations of both tribes. These numbers in the legend are trustworthy since everyone living on this island is immortal and none have ever been born at least these millennia.
You are a good computer programmer and so requested to help Akira by writing a program that classifies the inhabitants according to their answers to his inquiries.
Input
n p1 p2
xl yl a1
x2 y2 a2
...
xi yi ai
...
xn yn an
The first line has three non-negative integers n, p1, and p2. n is the number of questions Akira asked. pl and p2 are the populations of the divine and devilish tribes, respectively, in the legend. Each of the following n lines has two integers xi, yi and one word ai. xi and yi are the identification numbers of inhabitants, each of which is between 1 and p1 + p2, inclusive. ai is either yes, if the inhabitant xi said that the inhabitant yi was a member of the divine tribe, or no, otherwise. Note that xi and yi can be the same number since "are you a member of the divine tribe?" is a valid question. Note also that two lines may have the same x's and y's since Akira was very upset and might have asked the same question to the same one more than once.
You may assume that n is less than 1000 and that p1 and p2 are less than 300. A line with three zeros, i.e., 0 0 0, represents the end of the input. You can assume that each data set is consistent and no contradictory answers are included.
Output
Sample Input
2 1 1
1 2 no
2 1 no
3 2 1
1 1 yes
2 2 yes
3 3 yes
2 2 1
1 2 yes
2 3 no
5 4 3
1 2 yes
1 3 no
4 5 yes
5 6 yes
6 7 no
0 0 0
Sample Output
no
no
1
2
end
3
4
5
6
end
Source
输入三个数m, p, q 分别表示接下来的输入行数,天使数目,恶魔数目;
接下来m行输入形如x, y, a,a为yes表示x说y是天使,a为no表示x说y不是天使(x, y为天使,恶魔的编号,1<=x,y<=p+q);天使只说真话,恶魔只说假话;
如果不能确定所有天使的编号,输出no,若能确定,输出所有天使的编号,并且以end结尾
分析
参照ygeloutingyu的题解。
我们分析输入的数据不难发现,对于输入x, y, yes,假设x为天使,则y也为为天使,若x为恶魔,那么y也为恶魔,即x, y, 同为恶魔或者天使;
对于输入x, y, no,同理可得x, y, 一者为天使一者为恶魔;即可得ch为yes时,x, y, 属同种,ch为no时, x, y属异种
那么我们很容易就能想到带权并查集,d[x]表示x与其父亲节点的关系,d[x]=0表示x与其父亲节点属于同类,d[x]=1表示x与其父亲节点属于异类;通过并查集将能确定相对关系的编号放在一个集合里面,每个结合里面的编号可以分为两部分,和根节点属同种的的节点,以及和根节点属于异种的节点;这样并不能直接确定答案,我们确定了划分集合的个数以及每个集合里面和根节点同种的节点数目以及异节点的数目;从每个集合里面选择一种节点,若所有选中的节点数目和为p的选择方法唯一,那么我们能够确定所有天使的编号,反之则不能;关于这个问题我们可以用dp完美解决;
dp过程中记录下转移方案,最后倒推出答案即可。
时间复杂度\(O(n^2)\)
代码
#include<iostream>
#include<cstring>
#include<algorithm>
#define rg register
#define il inline
#define co const
template<class T>il T read(){
rg T data=0,w=1;rg char ch=getchar();
while(!isdigit(ch)) {if(ch=='-') w=-1;ch=getchar();}
while(isdigit(ch)) data=data*10+ch-'0',ch=getchar();
return data*w;
}
template<class T>il T read(rg T&x) {return x=read<T>();}
typedef long long ll;
co int N=1001;
int n,p1,p2,fa[N],d[N],s[2][N],f[N][N],g[N][N];
int a1[N],a2[N],p[N],ans[N];
int get(int x){
if(x==fa[x]) return x;
int root=get(fa[x]);
d[x]^=d[fa[x]];
return fa[x]=root;
}
void work(int a,int b,int k){
int x=get(a),y=get(b);
if(x==y) return;
fa[y]=x;
d[y]=k^d[a]^d[b];
s[0][x]+=s[d[y]][y]; // d[u]^d[y]=0
s[1][x]+=s[d[y]^1][y];
}
void True_Liars(){
memset(d,0,sizeof d);
for(int i=0;i<N;++i) fa[i]=i,s[0][i]=1,s[1][i]=0;
for(int i=1,a,b;i<=n;++i){
static char str[4];
read(a),read(b),scanf("%s",str);
work(a,b,str[0]!='y');
}
memset(a1,0,sizeof a1);
memset(a2,0,sizeof a2);
int cnt=0;
for(int i=1;i<=p1+p2;++i)if(i==get(i))
a1[++cnt]=s[0][i],a2[cnt]=s[1][i],p[cnt]=i;
memset(f,0,sizeof f);
f[0][0]=1;
memset(g,0,sizeof g);
for(int i=1;i<=cnt;++i){
for(int t=p1;t>=a1[i];--t)if(f[i-1][t-a1[i]])
f[i][t]+=f[i-1][t-a1[i]],g[i][t]=0;
for(int t=p1;t>=a2[i];--t)if(f[i-1][t-a2[i]])
f[i][t]+=f[i-1][t-a2[i]],g[i][t]=1;
}
if(f[cnt][p1]!=1) return puts("no"),void();
int num=0,now=p1+p2;
while(cnt>0){
int w=g[cnt][p1],k=p[cnt];
for(int i=1;i<=now;++i)
if(get(i)==k&&d[i]==w) ans[num++]=i;
p1-=w?a2[cnt]:a1[cnt],--cnt;
}
std::sort(ans,ans+num);
for(int i=0;i<num;++i) printf("%d\n",ans[i]);
puts("end");
}
int main(){
// freopen(".in","r",stdin),freopen(".out","w",stdout);
while(read(n)|read(p1)|read(p2)) True_Liars();
return 0;
}