结构struct动态数组创建与操作

时间:2021-09-23 00:36:38

在做hdoj的1009,本来这道题目不是很难,可是对于struct动态数组操作不是很熟,做了很久,在这里记录一下,避免下次继续出错。

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25384 Accepted Submission(s): 8029


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.


 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.


 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.


 

Sample Input
 
 
5 37 24 35 220 325 1824 1515 10-1 -1


 

Sample Output
13.333
31.500


代码如下:

#include<stdio.h>
#include<algorithm>
using namespace std;

struct trade{
int j;
int f;
};

bool compare(const trade &a, const trade &b){
return double(a.j)/double(a.f)>double(b.j)/double(b.f);
}

void main(){
int m,n;
double sum;
while(1){
sum=0.0;
scanf("%d %d",&m,&n);
if(m==-1)
break;
trade* array=new trade[n];
for(int i=0; i<n; i++){
scanf("%d %d",&array[i].j,&array[i].f);
}
sort(array,array+n,compare);
for(int j=0; j<n; j++){
if(m<array[j].f){
sum+=double(array[j].j)/double(array[j].f)*m;
break;
}
m-=array[j].f;
sum+=array[j].j;
}
printf("%.3f\n",sum);
delete []array;
}
}


其中,创建动态struct数组

struct struct_name * struct_array = new struct_name[struct_array_len];

输入struct数组元素值,记得不要落下&

scanf("%d",&struct_array[i].struct_member);

排序

sort(struct_array,struct_array+struct_array_len,compare);

释放

delete []struct_array;