Modular Inverse
Time Limit: 2 Seconds Memory Limit: 65536 KB
The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m)
. This is equivalent to ax≡1 (mod m)
.
Input
There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.
Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.
Output
For each test case, output the smallest positive x. If such x doesn't exist, output "Not Exist".
Sample Input
3
3 11
4 12
5 13
Sample Output
4
Not Exist
8
#include<cstdio>
int gcd(int a,int b)
{
return b==0?a:gcd(b,a%b);
}
int main()
{
int i,j,k;
int a,m;
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&a,&m);
if(gcd(a,m)!=1) {printf("Not Exist\n");continue;}
//排位赛的时候一直在这里wa掉,谨记:
//a三b(mod m) 是同余 即:a mod m == b mod m
//可表示成 a=b+m*k 其中k是从 0 开始
for(k=0;k<=1000;k++)
{
if((m*k+1)%a==0) {printf("%d\n",(m*k+1)/a);break;}
}
}
return 0;
}