一种排序
时间限制:3000 ms | 内存限制:65535 KB
难度:3
- 描述
- 现在有很多长方形,每一个长方形都有一个编号,这个编号可以重复;还知道这个长方形的宽和长,编号、长、宽都是整数;现在要求按照一下方式排序(默认排序规则都是从小到大);
1.按照编号从小到大排序
2.对于编号相等的长方形,按照长方形的长排序;
3.如果编号和长都相同,按照长方形的宽排序;
4.如果编号、长、宽都相同,就只保留一个长方形用于排序,删除多余的长方形;最后排好序按照指定格式显示所有的长方形;- 输入
- 第一行有一个整数 0<n<10000,表示接下来有n组测试数据;
每一组第一行有一个整数 0<m<1000,表示有m个长方形;
接下来的m行,每一行有三个数 ,第一个数表示长方形的编号,
第二个和第三个数值大的表示长,数值小的表示宽,相等
说明这是一个正方形(数据约定长宽与编号都小于10000); - 输出
- 顺序输出每组数据的所有符合条件的长方形的 编号 长 宽
- 样例输入
-
1
8
1 1 1
1 1 1
1 1 2
1 2 1
1 2 2
2 1 1
2 1 2
2 2 1 - 样例输出
-
1 1 1
1 2 1
1 2 2
2 1 1
2 2 1 -
<span style="font-size:14px;">import java.util.Arrays;
import java.util.Scanner; public class Main{
static class Num implements Comparable<Num>{
public int a,b,c;
public Num(int a,int b,int c){
this.a=a;
this.b=b;
this.c=c;
}
//实现接口方法
@Override
public int compareTo(Num o) {
if(o instanceof Num){
//int cmp = Integer.compare(a, o.a);
int cmp = a-o.a;
if(cmp!=0){ //a是第一个比较的,如果相同再比较下一个
return cmp;
}else if((b-o.b)!=0){
return b-o.b;
}else if((c-o.c)!=0){
return c-o.c;
}else{
return 0;
}
}
return 0;
}
public String toString(){
return a+" "+b+" "+c;
}
}
public static void main(String[] args){
Scanner sc = new Scanner(System.in);
int n = sc.nextInt();
for(int i=0;i<n;i++){
int m = sc.nextInt();
int a,b,c;
Num[] numArray = new Num[m];
for(int j=0;j<m;j++){
a=sc.nextInt();
b=sc.nextInt();
c=sc.nextInt();
if(b<c){
int temp=b;
b=c;
c=temp;
}
numArray[j]=new Num(a, b, c);
}
Arrays.sort(numArray);
System.out.println(numArray[0].toString());
for(int j=1;j<numArray.length;j++){
if(numArray[j].toString().equals(numArray[j-1].toString())){
continue;
}
System.out.println(numArray[j].toString());
}
}
}
}</span>