https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=117&page=show_problem&problem=2829
“Waiting for orders we held in the wood, word from the front never came By evening the sound of the gunfire was miles away Ah softly we moved through the shadows, slip away through the trees Crossing their lines in the mists in the fields on our hands and our knees And all that I ever, was able to see The fire in the air, glowing red, silhouetting the smoke on the breeze”
There is a war and it doesn’t look very promising for your country. Now it’s time to act. You have a commando squad at your disposal and planning an ambush on an important enemy camp located nearby. You have N soldiers in your squad. In your master-plan, every single soldier has a unique responsibility and you don’t want any of your soldier to know the plan for other soldiers so that everyone can focus on his task only. In order to enforce this, you brief every individual soldier about his tasks separately and just before sending him to the battlefield. You know that every single soldier needs a certain amount of time to execute his job. You also know very clearly how much time you need to brief every single soldier. Being anxious to finish the total operation as soon as possible, you need to find an order of briefing your soldiers that will minimize the time necessary for all the soldiers to complete their tasks. You may assume that, no soldier has a plan that depends on the tasks of his fellows. In other words, once a soldier begins a task, he can finish it without the necessity of pausing in between.
Input There will be multiple test cases in the input file. Every test case starts with an integer N (1 ≤ N ≤ 1000), denoting the number of soldiers. Each of the following N lines describe a soldier with two integers B (1 ≤ B ≤ 10000) & J (1 ≤ J ≤ 10000). B seconds are needed to brief the soldier while completing his job needs J seconds. The end of input will be denoted by a case with N = 0. This case should not be processed.
Output
For each test case, print a line in the format, ‘Case X: Y ’, where X is the case number & Y is the total number of seconds counted from the start of your first briefing till the completion of all jobs.
Sample Input
3
2 5
3 2
2 1
3
3 3
4 4
5 5
0
Sample Output
Case 1: 8
Case 2: 15
有n个部下,你给每个部下分配任务,第i个部下需要你用Bi分钟交代任务,然后他用Ji分钟去完成,你要想想怎么交代任务才能使所有任务尽快完成。你不能同时给他们交代任务,但是他们可以同时做任务
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
struct job
{
int j,b;
bool operator<(const job& x) const
{
return j>x.j;//如果j>x.j的话就返回true,否则就返回false
}
};
int main()
{
int N,b,j;
while(cin>>N)
{
int k=1;
if(N==0)
{
break;
}
vector<job> v;//创建vector对象
for(int i=0;i<N;i++)
{
cin>>b>>j;
v.push_back((job){j,b});//尾部插入数字,并且把完成任务的时间放前面
}
sort(v.begin(),v.end());//排序,默认从小到大
int s=0,ans=0;
for(int i=0;i<N;i++)
{
s=s+v[i].b;//布置任务
ans=max(ans,s+v[i].j);//看时间是否重叠
}
cout<<"Case"<<' '<<k++<<':'<<' '<<ans<<endl;
}
return 0;
}