E - 寻找大富翁

时间:2022-04-28 19:55:04

浙江桐乡乌镇共有n个人,请找出该镇上的前m个大富翁.
Input
输入包含多组测试用例.
每个用例首先包含2个整数n(0 < n<=100000)和m(0< m<=10),其中: n为镇上的人数,m为需要找出的大富翁数, 接下来一行输入镇上n个人的财富值.
n和m同时为0时表示输入结束.
Output
请输出乌镇前m个大富翁的财产数,财产多的排前面,如果大富翁不足m个,则全部输出,每组输出占一行.
Sample Input
3 1
2 5 -1
5 3
1 2 3 4 5
0 0
Sample Output
5
5 4 3


水题。直接sort就可以了。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<stack>
#include<algorithm>
using namespace std;


bool cmp(int a,int b)
{
return a>b;
}
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF&&(n!=0||m!=0))
{
int a[100001];
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
sort(a,a+n,cmp);
if(n>=m)
{
for(int i=0;i<m-1;i++)
{
printf("%d ",a[i]);
}
printf("%d\n",a[m-1]);
}
else
{
for(int i=0;i<n-1;i++)
{
printf("%d ",a[i]);
}
printf("%d\n",a[n-1]);
}
}
return 0;
}