1221: 高考签到题
Time Limit: 1 Sec Memory Limit: id=1221">Status
128 MB
Submit: 9 Solved: 4
[Submit][
Description
在直角坐标系中有一条抛物线y=ax^2+bx+c和一个点P(x,y),求点P到抛物线的最短距离d。
Input
多组数据。
5个整数a,b,c,x,y。前三个数构成抛物线的參数,后两个数x,y表示P点坐标。-200≤a,b,c,x,y≤200
Output
1个实数d。保留3位小数(四舍五入)
Sample Input
2 8 2 -2 6
Sample Output
2.437
HINT
Source
解析:三分求极值,三分枚举抛物线上到定点距离近期点的横坐标x,形成的距离函数是一个凹形的抛物线。
AC代码:
#include <bits/stdc++.h>
using namespace std; double dist(double x, double y, double xx, double yy){ //两点距离的平方
return (x - xx)*(x - xx) + (y - yy)*(y - yy);
} int main(){
int a, b, c, x, y;
while(~scanf("%d%d%d%d%d", &a, &b, &c, &x, &y)){
double L, R;
if(x < -b*1.0 / (2*a)){
L = -200;
R = -b / (2*a);
}
else{
L = -b / (2*a) - 1;
R = 200;
} for(int i=0; i<100; i++){ //三分结束条件能够用R - L < eps来推断,可是非常easy出错。循环一定次数也能够达到精度
double m = L + (R - L) / 3;
double mm = R - (R - L) / 3;
if(dist(m, a*m*m + b*m + c, x, y) < dist(mm, a*mm*mm + b*mm + c, x, y)) R = mm;
else L = m;
}
printf("%.3lf\n", sqrt(dist(L, a*L*L + b*L + c, x, y)));
}
return 0;
}