Time Limit:8000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
System Crawler (2015-04-10)
Description
On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.
Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.
When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.
If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).
Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
Input
The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.
Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
Output
Sample Input
2
4
3
3
3
Sample Output
2
1
3
-1
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define mid (L+R)/2
#define lson rt*2,L,mid
#define rson rt*2+1,mid+1,R
const int maxn=222222; //最多贴n个通告,所以就算h很大,只要满足n个通告就行了
int maxv[maxn*4];
void PushUP(int rt){
maxv[rt]=max(maxv[rt*2],maxv[rt*2+1]);
}
void build(int rt,int L,int R,int wid){
maxv[rt]=wid;
if(L==R){
return ;
}
build(lson,wid);
build(rson,wid);
}
int query(int rt,int L,int R,int len){
if(L==R){
maxv[rt]-=len;
return L;
}
int ret=0;
if(maxv[rt*2]>=len){
ret= query(lson,len);
}else {ret= query(rson,len);}
PushUP(rt);
return ret;
}
int main(){
int n,h,w;
while(scanf("%d%d%d",&h,&w,&n)!=EOF){
if(n<h){
h=n;
}
build(1,1,h,w);
for(int i=0;i<n;i++){
int len;
scanf("%d",&len);
if(maxv[1]<len)
printf("-1\n");
else
printf("%d\n",query(1,1,h,len)) ;
}
}
return 0;
}