PAT 1010 一元多项式求导 (25)(STL-map+思路)

时间:2022-05-23 06:51:59

1010 一元多项式求导 (25)(25 分)提问

设计函数求一元多项式的导数。(注:x^n^(n为整数)的一阶导数为n*x^n-1^。)

输入格式:以指数递降方式输入多项式非零项系数和指数(绝对值均为不超过1000的整数)。数字间以空格分隔。

输出格式:以与输入相同的格式输出导数多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。注意“零多项式”的指数和系数都是0,但是表示为“0 0”。

输入样例:

3 4 -5 2 6 1 -2 0

输出样例:

12 3 -10 1 6 0

PS:最近在深入学习STL,能用STL的尽量用了,这里没必要存储数据,我们可以输入一个判断一个,我

的方法就有些浪费了。。。

#include<iostream>
#include<map>
using namespace std;
map<int, int, greater<int>> in, put;
map<int, int>::iterator it;
int main() {
int a, b;
char ch;
while (1) {
cin >> a >> b;
in[b] += a;
ch = getchar(); //接收输入a、b之后的一个符号
if (ch == '\n')break; }
for (it = in.begin(); it != in.end(); it++) {
if (it->first != 0)
put[it->first - 1] += it->first*it->second;
else
put[it->first] += 0;
}
it = put.begin();
if (it->second||(it->first==0&&it->second==0))
cout << it->second << " " << it->first;
it++;
for (; it != put.end(); it++) {
if(it->second)
cout << " " << it->second << " " << it->first;
}
return 0;
}