练习2 C - 成绩转换

时间:2021-06-24 16:21:31
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
 

Description

输入一个百分制的成绩t,将其转换成对应的等级,具体转换规则如下:  90~ 100为A;  80~ 89为B;  70~ 79为C;  60~ 69为D;  0~ 59为E;

Input

输入数据有多组,每组占一行,由一个整数组成。

Output

对于每组输入数据,输出一行。如果输入数据不在0~ 100范围内,请输出一行:“Score is error!”。

Sample Input

56
67
100
123

Sample Output

E
D
A
Score is error!
 
多次判断,注意条件限制和格式输出
#include<stdio.h>
int main()
{
int x;
while(scanf("%d",&x)!=EOF)
{
if(x>)
printf("Score is error!\n");
else if
(x>=)printf("A\n");
else if
(x>=)printf("B\n");
else if
(x>=)printf("C\n");
else if
(x>=)printf("D\n");
else if
(x>=)printf("E\n");
else
printf("Score is error!\n");
}
return ;
}