Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 21518 | Accepted: 8367 |
Description
Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as
1/Σ(to,td)d(to,td)
where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.
Input
Output
Sample Input
4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0
Sample Output
The highest possible quality is 1/3. 我也是挺纳闷 为什么我把 建图和prime算法过程 写作子函数放在main函数外边怎么就不能调用呢?
题意:给出卡车的编号,编号是一个长度为7的字符串,一个编号由另一个编号衍生出来,而衍生出来所需要的代价就是两个编号之间不同字符的个数
(相当于两个顶点相连后的权值),现在求给出的这组字符串所需要的最小代价
#include<stdio.h>
#include<string.h>
#define MAX 2010
#define INF 0x3ffffff
int map[MAX][MAX];
char s[MAX][11];
int low[MAX],vis[MAX];
int t;
int fun(int i,int j)
{
int ans=0;
for(int k=0;k<7;k++)
{
if(s[i][k]!=s[j][k])
ans++;
}
return ans;
}
void init()
{
int i,j;
for(i=0;i<t;i++)
{
for(j=0;j<t;j++)
{
if(i==j)
map[i][j]=0;
else
map[i][j]=INF;
}
}
}
int main()
{
int t;
int i,j;
while(scanf("%d",&t),t)
{
init();
for(i=0;i<t;i++)
scanf("%s",s[i]);
for(i=0;i<t-1;i++)
{
for(j=i+1;j<t;j++)
{
map[i][j]=map[j][i]=fun(i,j);
}
}
int next,min,mindis=0;
memset(vis,0,sizeof(vis));
for(i=0;i<t;i++)
low[i]=map[0][i];
vis[0]=1;
for(i=0;i<t-1;i++)
{
min=INF;
for(j=0;j<t;j++)
{
if(!vis[j]&&min>low[j])
{
min=low[j];
next=j;
}
}
mindis+=min;
vis[next]=1;
for(j=0;j<t;j++)
{
if(!vis[j]&&low[j]>map[next][j])
low[j]=map[next][j];
}
}
printf("The highest possible quality is 1/%d.\n",mindis);
}
return 0;
}