cisco交换机Telnet配置
switch>en ;第一次密码为空
switch#conf t ;进入全局配置模式
switch(config)#hostname swa ;设置交换机名
swa(config)#enable secret 456 ;设置特权加密口令为(即:从普通模式进入特权(en)模式的口令为:456)
swa(config)#enable password 789 ;设置特权非密口令为:789
swa(config)#line console 0 ;进入控制台口(Rs232)
swa(config-line)#password 999 ;设置登录口令为:999(即:登录到交换机的配置状态,就是普通用户模式啦)举个例子加入你现在在特权(en)模式想返回到普通模式下,呵呵是要输入这个密码的。
swa(config-line)#login ;登录要求口令验证
swa(config-line)#line vty 0 4 ;进入虚拟终端virtual tty
swa(config-line)#password 123 ;设置登录口令(即:从远程pc机Telnet到交换机时代登录口令为:123)
swa(config-line)#login ;登录要求口令验证
swa(config-line)#exit ;返回上一层
swa(config)#exit ;返回上一层
swa#sh run ;看配置信息
swa#exit ;返回命令 (注:1.蓝色字体的配置可以省略 2.另外:一般都是配enable secret 因为安全度高,如果你同时配了enable secret和enable password的时候,后者就失效了,登陆的时候,只需输入enable secret的密码即可。)
在配置之前要还要给交换机配置管理IP。配置如下 RA#
RA#conf t
RA(config)#interface vlan 1
RA(config-if)#ip address 192.168.2.100 255.255.255.0
RA(config-if)#no shutdown %LINK-5-CHANGED: Interface Vlan1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
RA(config-if)#exit
RA(config)#exit
RA#
switch#conf t
switch(config)#hostname swa
swa(config)#enable secret 456
swa(config)#enable password 789
swa(config)#line console 0
swa(config-line)#password 999
swa(config-line)#login
swa(config-line)#line vty 0 4
swa(config-line)#password 123
swa(config-line)#login
swa(config-line)#exit
swa(config)#exit
swa#sh run
swa#exit
RA#conf t
RA(config)#interface vlan 1
RA(config-if)#ip address 192.168.2.100 255.255.255.0
RA(config-if)#no shutdown %LINK-5-CHANGED: Interface Vlan1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
RA(config-if)#exit
RA(config)#exit
RA#