hdu 5391 (数论)

时间:2020-12-17 14:47:42

Zball in Tina Town

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1401    Accepted Submission(s): 727

Problem Description
Tina Town is a friendly place. People there care about each other.

Tina has a ball called zball. Zball is magic. It grows larger every day. On the first day, it becomes $1$ time as large as its original size. On the second day,it will become $2$ times as large as the size on the first day. On the n-th day,it will become $n$
times as large as the size on the (n-1)-th day. Tina want to know its size on the (n-1)-th day modulo n.

 
Input
The first line of input contains an integer $T$, representing the number of cases.

The following $T$ lines, each line contains an integer $n$, according to the description.
$ T \leq {10}^{5},2 \leq n \leq {10}^{9} $

 
Output
For each test case, output an integer representing the answer.

Sample Input
2
3
10
 
Sample Output
2
0

题意:求 (n-1)%n,

合数为0,因为1 ~ n-1中必定有积为n(除了4)

质数为n-1,威尔逊定理( p -1 )! ≡ -1 ( mod p )

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
typedef long long ll;
#define N 100005
#define mod 258280327
#define MIN 0
#define MAX 1000001 bool prim(int u)
{
for(int i = 2; i*i <= u; i++)
if(u % i == 0)
return false;
return true;
} int main()
{
int n,T;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
if(n == 4)
printf("2\n");
else if(n == 1)
printf("0\n");
else
{
if(prim(n))
printf("%d\n",n-1);
else
printf("%d\n",0);
}
}
return 0;
}