HDU 3938 Portal(离线+Kruskal+并查集)

时间:2022-03-08 11:12:00

链接:

http://acm.hdu.edu.cn/showproblem.php?pid=3938


题目:

Problem Description
ZLGG found a magic theory that the bigger banana the bigger banana peel .This important theory can help him make a portal in our universal. Unfortunately, making a pair of portals will cost min{T} energies. T in a path between point V and point U is the length of the longest edge in the path. There may be lots of paths between two points. Now ZLGG owned L energies and he want to know how many kind of path he could make.
 

Input
There are multiple test cases. The first line of input contains three integer N, M and Q (1 < N ≤ 10,000, 0 < M ≤ 50,000, 0 < Q ≤ 10,000). N is the number of points, M is the number of edges and Q is the number of queries. Each of the next M lines contains three integers a, b, and c (1 ≤ a, b ≤ N, 0 ≤ c ≤ 10^8) describing an edge connecting the point a and b with cost c. Each of the following Q lines contain a single integer L (0 ≤ L ≤ 10^8).
 

Output
Output the answer to each query on a separate line.
 

Sample Input
 
 
10 10 10 7 2 1 6 8 3 4 5 8 5 8 2 2 8 9 6 4 5 2 1 5 8 10 5 7 3 7 7 8 8 10 6 1 5 9 1 8 2 7 6
 

Sample Output
 
 
36 13 1 13 36 1 36 2 16 13

分析与总结:

做这题学到了什么是“离线算法”的概念。所谓“离线”,就是把所有的数据都输入之后再计算,“在线”就是边输入边计算。

用在这题中,是因为输入中的“询问部分”,有Q 个问,每个L可以有多少种不同路径。由于大的L必定会包含到小的L, 所以把所有问题都输入,再从大到小排序,再计算,可以减少很多计算量。

这题还需要用到的是并查集中的“权值”, 用rank数组表示,也就是某个棵树k有rank【k】个结点。同一个树之间的点都是连通的,任何点都可以通往其它的任意点, 那么当两颗树合并成一棵树时, 将会增加rank[a]*rank[b]条路径。


代码:

#include<cstdio>
#include<algorithm>
using namespace std;
#define N 10005
int f[N], rank[N], ans[N], n, m, Q;

struct Edge{
    int u, v, val;
    friend bool operator < (const Edge&a,const Edge&b){
        return a.val < b.val;
    }
}arr[N*5];

struct Query{
    int id, L;
    friend bool operator<(const Query&a,const Query&b){
        return a.L<b.L;
    }
}q[N];

void init(){
    for(int i=0; i<=n; ++i)
        f[i]=i, rank[i]=1;
}
int find(int x){
    int i, j=x;
    while(j!=f[j]) j=f[j];
    while(x!=j){ i=f[x]; f[x]=j; x=i; }
    return j;
}
int Union(int x,int y){
    int a=find(x), b=find(y);
    if(a==b) return 0;
    int t=rank[a]*rank[b];
    rank[a] += rank[b];
    f[b] = a;
    return t;
}

int main(){
    while(~scanf("%d%d%d",&n,&m,&Q)){
        
        for(int i=0; i<m; ++i) 
            scanf("%d%d%d",&arr[i].u,&arr[i].v,&arr[i].val);
        for(int i=0; i<Q; ++i) 
            scanf("%d",&q[i].L), q[i].id=i;
        
        sort(arr,arr+m);
        sort(q,q+Q);
        
        int cnt=0, j=0;
        init();
        for(int i=0; i<Q; ++i){
            while(j<m && arr[j].val<=q[i].L){
                cnt += Union(arr[j].u, arr[j].v);
                ++j;
            }
            ans[q[i].id] = cnt;
        }
        
        for(int i=0; i<Q; ++i)
            printf("%d\n", ans[i]);
    }
    return 0;
}



 

——  生命的意义,在于赋予它意义。

          
     原创 http://blog.csdn.net/shuangde800 , By   D_Double  (转载请标明)