Problem F: 多少个最大值?

时间:2021-01-17 10:49:54

Description

输入若干个int类型的整数,求它们的最大值及其个数。

Input

输入 若干个int类型的整数,至文件尾为止。

Output

输出只有一行:There are # maximum number &.

其中#是最大值的个数,&是最大值。

Sample Input

1 2 3 4 5 6 6 5 4 3 2 1 6 6 6

Sample Output

There are 5 maximum number 6.
#include <iostream>
#include <algorithm>
#include <string>
#include <cmath>
using namespace std;
int main()
{
    int inum=0;
    int imax=-9999999;
    int t;
    while(cin>>t)
    {
        int tem=imax;
        imax=max(imax,t);
        if(tem==imax&&tem==t)
            inum++;
        else if(tem<imax)
            inum=1;
    }
    cout<<"There are "<<inum<<" maximum number "<<imax<<"."<<endl;
}