Parallelogram Counting(求平行四边形个数)

时间:2021-07-02 10:08:06
Parallelogram Counting
Time Limit: 5000MS
Memory Limit: 65536K
Total Submissions: 5605
Accepted: 1885

Description

There are n distinct points in the plane, given by their integer coordinates. Find the number of parallelograms whose vertices lie on these points. In other words, find the number of 4-element subsets of these points that can be written as {A, B, C, D} such that AB || CD, and BC || AD. No four points are in a straight line.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases. It is followed by the input data for each test case. 
The first line of each test case contains an integer n (1 <= n <= 1000). Each of the next n lines, contains 2 space-separated integers x and y (the coordinates of a point) with magnitude (absolute value) of no more than 1000000000. 

Output

Output should contain t lines. 
Line i contains an integer showing the number of the parallelograms as described above for test case i. 

Sample Input

2
6
0 0
2 0
4 0
1 1
3 1
5 1
7
-2 -1
8 9
5 7
1 1
4 8
2 0
9 8

Sample Output

5
6
给你n个点,问最多可以形成多少个平行四边形:
利用平行四边形对角线互相平分原理,对其进行扩展,求任意两点重点,然后排序,利用排列组合从中抽取两点即可;
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
struct none{
	int x,y;
}no[10000],n1[1000000];
bool cmp(none x,none y)
{if(x.x!=y.x)
return  x.x<y.x;
else
return x.y<y.y; 
}
int main()
{int t,n,m=1,k;
scanf("%d",&t);
while(t--)
{scanf("%d",&n);
k=0;
for(int i=0;i<n;i++)
scanf("%d%d",&no[i].x,&no[i].y);
for(int i=0;i<n-1;i++)
for(int j=i+1;j<n;j++)
{n1[k].x=no[i].x+no[j].x;
n1[k].y=no[i].y+no[j].y;
k++;
}
sort(n1,n1+k,cmp);
long long ans=0,T=1;
for(int i=1;i<k;i++)
{if(n1[i].x==n1[i-1].x&&n1[i].y==n1[i-1].y)
T++;
else
{ans=ans+T*(T-1)/2;
T=1;
}
}
printf("Case %d: %lld\n",m++,ans);
}}