Hdu1427 速算24点 2017-01-18 17:26 46人阅读 评论(0) 收藏

时间:2021-06-20 07:10:06

速算24点

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 34   Accepted Submission(s) : 18

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

速算24点相信绝大多数人都玩过。就是随机给你四张牌,包括A(1),2,3,4,5,6,7,8,9,10,J(11),Q(12),K(13)。要求只用'+','-','*','/'运算符以及括号改变运算顺序,使得最终运算结果为24(每个数必须且仅能用一次)。游戏很简单,但遇到无解的情况往往让人很郁闷。你的任务就是针对每一组随机产生的四张牌,判断是否有解。我们另外规定,整个计算过程中都不能出现小数。

Input

每组输入数据占一行,给定四张牌。

Output

每一组输入数据对应一行输出。如果有解则输出"Yes",无解则输出"No"。

Sample Input

A 2 3 6
3 3 8 8

Sample Output

Yes
No

————————————————————————————————————————————————

4个数通过 +,—,*,/和加括号,计算得24,

枚举数字和运算符,DFS即可,注意题目要求计算过程中都不能出现小数,所以做除法时稍作处理

枚举数组可用algorithm里的next_permutation



#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<queue>
#include<cstring>
#include<cstdlib>
using namespace std;
const int INF=9999999;
int a[10],p[10]; int jisuan(int a,int b,int x)
{
if(x==0)
return a+b;
if(x==1)
return a-b;
if(x==2)
return a*b;
if(x==3)
{
if(b==0)
return INF;
if(a%b!=0)
return INF;
return a/b;
}
} int dfs()
{
for(p[0]=0; p[0]<4; p[0]++)
for(p[1]=0; p[1]<4; p[1]++)
for(p[2]=0; p[2]<4; p[2]++)
{
int x1=0,x2=0,x3=0;
x1=jisuan(a[0],a[1],p[0]);
if(x1!=INF)x2=jisuan(x1,a[2],p[1]);
if(x2!=INF)x3=jisuan(x2,a[3],p[2]);
if(x1!=INF&&x2!=INF&&abs(x3)==24)
return 1; x1=0,x2=0,x3=0;
x1=jisuan(a[0],a[1],p[0]);
x2=jisuan(a[2],a[3],p[2]);
if(x1!=INF&&x2!=INF) x3=jisuan(x1,x2,p[1]);
if(x1!=INF&&x2!=INF&&abs(x3)==24)
return 1; }
return 0;
} int main()
{
char s[1000];
int k,cnt;
int ans;
while(gets(s)!=NULL)
{
cnt=0;
k=strlen(s);
for(int i=0; i<k; i++)
{
if(s[i]=='A')
a[cnt++]=1;
else if(s[i]>='2'&&s[i]<='9')
a[cnt++]=s[i]-'0';
else if(s[i]=='1')
{
a[cnt++]=10;
i++;
}
else if(s[i]=='J')
a[cnt++]=11;
else if(s[i]=='Q')
a[cnt++]=12;
else if(s[i]=='K')
a[cnt++]=13;
} sort(a,a+4);
do
{
ans=dfs();
if(ans)
break;
}
while (next_permutation(a,a+4));
if(ans)
printf("Yes\n");
else
printf("No\n");
}
return 0;
}