hdoj 5137 How Many Maos Does the Guanxi Worth【最短路枚举+删边】

时间:2022-03-13 07:01:44

How Many Maos Does the Guanxi Worth

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 1027    Accepted Submission(s):
349

Problem Description
"Guanxi" is a very important word in Chinese. It kind
of means "relationship" or "contact". Guanxi can be based on friendship, but
also can be built on money. So Chinese often say "I don't have one mao (0.1 RMB)
guanxi with you." or "The guanxi between them is naked money guanxi." It is said
that the Chinese society is a guanxi society, so you can see guanxi plays a very
important role in many things.

Here is an example. In many cities in
China, the government prohibit the middle school entrance examinations in order
to relief studying burden of primary school students. Because there is no clear
and strict standard of entrance, someone may make their children enter good
middle schools through guanxis. Boss Liu wants to send his kid to a middle
school by guanxi this year. So he find out his guanxi net. Boss Liu's guanxi net
consists of N people including Boss Liu and the schoolmaster. In this net, two
persons who has a guanxi between them can help each other. Because Boss Liu is a
big money(In Chinese English, A "big money" means one who has a lot of money)
and has little friends, his guanxi net is a naked money guanxi net -- it means
that if there is a guanxi between A and B and A helps B, A must get paid.
Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for
help, and then B may ask C for help ...... If the request finally reaches the
schoolmaster, Boss Liu's kid will be accepted by the middle school. Of course,
all helpers including the schoolmaster are paid by Boss Liu.

You hate
Boss Liu and you want to undermine Boss Liu's plan. All you can do is to
persuade ONE person in Boss Liu's guanxi net to reject any request. This person
can be any one, but can't be Boss Liu or the schoolmaster. If you can't make
Boss Liu fail, you want Boss Liu to spend as much money as possible. You should
figure out that after you have done your best, how much at least must Boss Liu
spend to get what he wants. Please note that if you do nothing, Boss Liu will
definitely succeed.

 
Input
There are several test cases.

For each test
case:

The first line contains two integers N and M. N means that there
are N people in Boss Liu's guanxi net. They are numbered from 1 to N. Boss Liu
is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss
Liu's guanxi net. (3 <=N <= 30, 3 <= M <= 1000)

Then M lines
follow. Each line contains three integers A, B and C, meaning that there is a
guanxi between A and B, and if A asks B or B asks A for help, the helper will be
paid C RMB by Boss Liu.

The input ends with N = 0 and M = 0.

It's
guaranteed that Boss Liu's request can reach the schoolmaster if you do not try
to undermine his plan.

 
Output
For each test case, output the minimum money Boss Liu
has to spend after you have done your best. If Boss Liu will fail to send his
kid to the middle school, print "Inf" instead.
 
Sample Input
4 5
1 2 3
1 3 7
1 4 50
2 3 4
3 4 2
3 2
1 2 30
2 3 10
0 0
 
Sample Output
50
Inf
 
题意:给你n个点和m条边的无向图,问你删除其中任意一条边能否让1到n不连通,如果可以输出Inf否则输出从1到n的的最大权值
题解:每次删除一条边(注意,1与n直接相连的边不可以删除)判断是否联通;
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
#define MAX 1010
#define INF 0x3f3f3f
using namespace std;
int n,m;
int low[MAX],map[MAX][MAX];
int vis[MAX];
void init()
{
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
map[i][j]=i==j?0:INF;
}
void getmap()
{
int i,j;
int a,b,c;
while(m--)
{
scanf("%d%d%d",&a,&b,&c);
if(map[a][b]>c)
map[a][b]=map[b][a]=c;
}
}
int dijkstra()
{
int i,j,next,min;
memset(vis,0,sizeof(vis));
for(i=1;i<=n;i++)
low[i]=map[1][i];
vis[1]=1;
for(i=2;i<=n;i++)
{
min=INF;
next=1;
for(j=1;j<=n;j++)
{
if(!vis[j]&&min>low[j])
{
next=j;
min=low[j];
}
}
vis[next]=1;
for(j=1;j<=n;j++)
{
if(!vis[j]&&low[j]>low[next]+map[next][j])
low[j]=low[next]+map[next][j];
}
}
return low[n];
}
int used[MAX][MAX];//记录被删边的权值
void solve()
{
int i,j;
int ans=dijkstra();
bool flag=false;
for(i=2;i<=n-1;i++)
{
for(j=1;j<=n;j++)
{
used[i][j]=used[j][i]=map[i][j];//将要删的边的权值记录下来
map[i][j]=map[j][i]=INF;//删边
}
if(dijkstra()==INF)//删边之后1到n不连通
{
flag=true;
break;
}
ans=max(dijkstra(),ans);//如果删边后任然联通,取最长路
for(j=1;j<=n;j++)//将这条边恢复,删除下一条边
map[i][j]=map[j][i]=used[i][j];
}
if(flag)
printf("Inf\n");
else
printf("%d\n",ans);
}
int main()
{
while(scanf("%d%d",&n,&m),n|m)
{
init();
getmap();
solve();
}
return 0;
}