Hardwood Species 分类: POJ 树 2015-08-05 16:24 2人阅读 评论(0) 收藏

时间:2022-11-18 06:50:09

Hardwood Species

Time Limit: 10000MS Memory Limit: 65536K

Total Submissions: 20619 Accepted: 8083

Description

Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter.

America’s temperate climates produce forests with hundreds of hardwood species – trees that share certain biological characteristics. Although oak, maple and cherry all are types of hardwood trees, for example, they are different species. Together, all the hardwood species represent 40 percent of the trees in the United States.

On the other hand, softwoods, or conifers, from the Latin word meaning “cone-bearing,” have needles. Widely available US softwoods include cedar, fir, hemlock, pine, redwood, spruce and cypress. In a home, the softwoods are used primarily as structural lumber such as 2x4s and 2x6s, with some limited decorative applications.

Using satellite imaging technology, the Department of Natural Resources has compiled an inventory of every tree standing on a particular day. You are to compute the total fraction of the tree population represented by each species.

Input

Input to your program consists of a list of the species of every tree observed by the satellite; one tree per line. No species name exceeds 30 characters. There are no more than 10,000 species and no more than 1,000,000 trees.

Output

Print the name of each species represented in the population, in alphabetical order, followed by the percentage of the population it represents, to 4 decimal places.

Sample Input

Red Alder

Ash

Aspen

Basswood

Ash

Beech

Yellow Birch

Ash

Cherry

Cottonwood

Ash

Cypress

Red Elm

Gum

Hackberry

White Oak

Hickory

Pecan

Hard Maple

White Oak

Soft Maple

Red Oak

Red Oak

White Oak

Poplan

Sassafras

Sycamore

Black Walnut

Willow

Sample Output

Ash 13.7931

Aspen 3.4483

Basswood 3.4483

Beech 3.4483

Black Walnut 3.4483

Cherry 3.4483

Cottonwood 3.4483

Cypress 3.4483

Gum 3.4483

Hackberry 3.4483

Hard Maple 3.4483

Hickory 3.4483

Pecan 3.4483

Poplan 3.4483

Red Alder 3.4483

Red Elm 3.4483

Red Oak 6.8966

Sassafras 3.4483

Soft Maple 3.4483

Sycamore 3.4483

White Oak 10.3448

Willow 3.4483

Yellow Birch 3.4483

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceeded.

Source

Waterloo Local 2002.01.26

题意:给你树的名字,统计每种树在所有树中所占的比例;

做法:题意中只说不超过30个字符,却没有说字符的范围,敲了字典树RE,果断的换二叉排序树

#include <map>
#include <list>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <string>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
#define eps 1e-9
#define LL long long
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define CRR fclose(stdin)
#define CWW fclose(stdout)
#define RR freopen("input.txt","r",stdin)
#pragma comment(linker, "/STACK:102400000")
#define WW freopen("output.txt","w",stdout) const int MAX = 300010; struct node
{
int num;
char str[35];
node *L;
node *R;
} Tree;
char s[35];
int sum;
node * Creat()
{
node *p;
p=new node;
p->num=1;
p->R=NULL;
p->L=NULL;
p->str[0]='\0';
return p;
}
void BuildSortTree(node *Root)
{
if(strcmp(Root->str,s)==0)
{
Root->num++;
return ;
}
if(strcmp(Root->str,s)>0)
{
if(Root->L==NULL)
{
Root->L=Creat();
strcpy(Root->L->str,s);
return ;
}
else
{
BuildSortTree(Root->L);
}
}
else
{
if(Root->R==NULL)
{
Root->R=Creat();
strcpy(Root->R->str,s);
return ;
}
else
{
BuildSortTree(Root->R);
}
} }
void DFS_Tree(node *p)//中序遍历
{
if(p==NULL)
{
return;
}
DFS_Tree(p->L);
printf("%s %.4f\n",p->str,p->num*100.0/sum);
DFS_Tree(p->R);
}
int main()
{
Tree.num=1;
Tree.R=NULL;
Tree.L=NULL;
sum=0;
while(gets(s))
{
if(sum==0)
{
strcpy(Tree.str,s);
}
else
{
BuildSortTree(&Tree);
}
sum++;
}
DFS_Tree(&Tree);
return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。