Description
While this is somewhat pointless with only a few dominoes, some people went to the opposite extreme in the early Eighties. Using millions of dominoes of different colors and materials to fill whole halls with elaborate patterns of falling dominoes, they created (short-lived) pieces of art. In these constructions, usually not only one but several rows of dominoes were falling at the same time. As you can imagine, timing is an essential factor here.
It is now your task to write a program that, given such a system of rows formed by dominoes, computes when and where the last domino falls. The system consists of several ``key dominoes'' connected by rows of simple dominoes. When a key domino falls, all rows connected to the domino will also start falling (except for the ones that have already fallen). When the falling rows reach other key dominoes that have not fallen yet, these other key dominoes will fall as well and set off the rows connected to them. Domino rows may start collapsing at either end. It is even possible that a row is collapsing on both ends, in which case the last domino falling in that row is somewhere between its key dominoes. You can assume that rows fall at a uniform rate.
Input
The following m lines each contain three integers a, b, and l, stating that there is a row between key dominoes a and b that takes l seconds to fall down from end to end.
Each system is started by tipping over key domino number 1.
The file ends with an empty system (with n = m = 0), which should not be processed.
Output
Sample Input
2 1
1 2 27
3 3
1 2 5
1 3 5
2 3 5
0 0
Sample Output
System #1
The last domino falls after 27.0 seconds, at key domino 2. System #2
The last domino falls after 7.5 seconds, between key dominoes 2 and 3.
题目大意:给你n个关键的多米诺骨牌,这n个关键的多米诺骨牌由m条由骨牌组成的“路”相连,每条路都有自己的“长度”,当这n个骨牌中的任意一个骨牌 k 倒塌时,与k相连的所有“路”上的骨牌也会随之而倒,让你求把骨牌 1 推到后,所有骨牌中最后一个倒塌的骨牌距离骨牌1的最短距离。
解题思路:题目中保证图是连通的,我们可以先求出骨牌1到其他(n - 1)个关键骨牌的最短距离,得到这些距离中的最大值MAX,然后枚举图中的每条边,再更新MAX,具体详解请看程序:
#include<iostream>
#include<string>
#include<algorithm>
#include<cstring>
#include<queue>
#include<cmath>
#include<vector>
#include<cstdio>
using namespace std ;
int n , m ;
const int MAXN = 505 ;
struct Node
{
int adj ;
double dis ;
};
const int INF = 0x7fffffff ;
int t ;
vector<Node> vert[MAXN] ;
double d[MAXN] ; // 保存顶点 1 到其他(n - 1)个顶点的最短距离
void clr() // 初始化
{
int i ;
for(i = 0 ; i < MAXN ; i ++)
vert[i].clear() ;
memset(d , 0 ,sizeof(d)) ;
}
void init()
{
clr() ;
int i , j ;
Node tmp ;
for(i = 0 ; i < m ; i ++) // 用邻接表建图
{
int a , b ;
double c ;
scanf("%d%d%lf" , &a , &b , &c) ; tmp.adj = b ;
tmp.dis = c ;
vert[a].push_back(tmp) ; tmp.adj = a ;
tmp.dis = c ;
vert[b].push_back(tmp) ;
}
}
queue<int> q ;
bool inq[MAXN] ;
void spfa(int u) // 求最短路
{
while (!q.empty())
q.pop() ;
q.push(u) ;
inq[u] = true ;
d[u] = 0 ;
int tmp ;
Node v ;
while (!q.empty())
{
tmp = q.front() ;
q.pop() ;
inq[tmp] = false ;
int i ;
for(i = 0 ; i < vert[tmp].size() ; i ++)
{
v = vert[tmp][i] ;
if(d[tmp] != INF && d[tmp] + v.dis < d[v.adj])
{
d[v.adj] = d[tmp] + v.dis ;
if(!inq[v.adj])
{
q.push(v.adj) ;
inq[v.adj] = true ;
}
}
}
}
}
void solve()
{
memset(inq , 0 , sizeof(inq)) ;
int i , j ;
for(i = 1 ; i <= n ; i ++)
{
d[i] = INF ;
}
spfa(1) ;
double MAX = d[1] ;
int MAXb = 1 ;
for(i = 1 ; i <= n ; i ++)
{
if(MAX < d[i])
{
MAX = d[i] ;
MAXb = i ;
}
}
int pan = 0 ;
int t1 , t2 ;
for(i = 1 ; i <= n ; i ++) // 枚举每条边 , 更新MAX
{
for(j = 0 ; j < vert[i].size() ; j ++)
{
Node tn = vert[i][j] ;
int ta = tn.adj ;
double td = tn.dis ;
if((d[i] + d[ta] + td) / 2 > MAX ) // 注意:最大距离的求法
{
pan = 1 ;
MAX = (d[i] + d[ta] + td) / 2;
if(i < ta)
{
t1 = i ;
t2 = ta ;
}
else
{
t1 = ta ;
t2 = i ;
}
}
}
}
printf("The last domino falls after %.1f seconds," , MAX) ;
if(pan)
{
printf(" between key dominoes %d and %d.\n" , t1 , t2) ;
}
else
{
printf(" at key domino %d.\n" , MAXb) ;
}
puts("") ;
}
int ca ;
int main()
{
ca = 0 ;
while (scanf("%d%d" , &n , &m) != EOF)
{
if(n == 0 && m == 0)
break ;
init() ;
printf("System #%d\n" , ++ ca) ;
solve() ;
}
return 0 ;
}