The shortest problem
http://acm.hdu.edu.cn/showproblem.php?pid=5373
Time Limit: 3000/1500 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 181 Accepted Submission(s):
92
Problem Description
In this problem, we should solve an interesting game.
At first, we have an integer n, then we begin to make some funny change. We sum
up every digit of the n, then insert it to the tail of the number n, then let
the new number be the interesting number n. repeat it for t times. When n=123
and t=3 then we can get 123->1236->123612->12361215.
At first, we have an integer n, then we begin to make some funny change. We sum
up every digit of the n, then insert it to the tail of the number n, then let
the new number be the interesting number n. repeat it for t times. When n=123
and t=3 then we can get 123->1236->123612->12361215.
Input
Multiple input.
We have two integer n
(0<=n<=104
We have two integer n
(0<=n<=104
) , t(0<=t<=105
) in each row.
When n==-1 and t==-1 mean the end of input.
Output
For each input , if the final number are divisible by
11, output “Yes”, else output ”No”. without quote.
11, output “Yes”, else output ”No”. without quote.
Sample Input
35 2
35 1
-1 -1
Sample Output
Case #1: Yes
Case #2: No
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <malloc.h>
#define Max(a,b) (a>b?a:b)
#define Min(a,b) (a<b?a:b)
#define MAX 999999999
#define LL long long
#define M 6666666
using namespace std;
int main()
{
int n,m,i,j,k,l,cas=;
while(~scanf("%d%d",&n,&m))
{
if(n==-&&m==-)break;
if(m==)
{
if(n%==)printf("Case #%d: Yes\n",cas++);
else printf("Case #%d: No\n",cas++);
continue;
}
k=n;
l=;
while(k>)
{
l+=k%;
k/=;
}//cout<<l<<endl;
while(m--)
{
k=l;//cout<<l<<" ";
while(k>)
{
k/=;
n*=;
}
n=(n+l)%;
k=l;
while(k>)
{
l+=k%;
k/=;//cout<<l<<endl;
}
}
if(n==)printf("Case #%d: Yes\n",cas++);
else printf("Case #%d: No\n",cas++);
}
return ;
}
Source