HDU 1577 WisKey的眼神 (GCD求直线上的点数)

时间:2022-04-19 05:18:29

WisKey的眼神

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2979    Accepted Submission(s): 938

Problem Description WisKey的眼镜有500多度,所以眼神不大好,而且他有个习惯,就是走路喜欢看着地(不是为了拣钱哦^_^),所以大家下次碰见他的时候最好主动打下招呼,呵呵.
但是Rabbit总是喜欢扮神秘,一天WisKey去食堂排队等着买饭,突然收到一道短消息,是Rabbit发的,”呵呵,又看见你了,你没看到我吧”.WisKey马上拉长脖子扫描食堂,可是就是看不到,再发短信问Rabbit在哪,Rabbit回信曰”我已经在寝室了”.WisKey无语....
假设食堂是个正方形,食堂中心坐标为(0,0),长度为2*L, WisKey保证在食堂内.
因为是吃饭高峰期,所以每个点上都站着人,当某些人处在同一直线上时就有可能被前面的人挡住.
聪明的ACMer请你帮帮WisKey,告诉他能不能看见Rabbit.
HDU 1577 WisKey的眼神 (GCD求直线上的点数)
 
Input 输入L,sx,sy,px,py; L<=1000,sx,sy是WisKey的坐标,px,py是Rabbit的坐标.
以L=0为结束.
Output 对于每组输入数据,能看见输出”Yes”,看不见输出”No”.
Rabbit不在食堂输出”Out Of Range”.
Sample Input
5 0 0 1 1
5 0 0 2 0
5 0 0 6 6
5 0 0 -1 -1
0
Sample Output
Yes
No
Out Of Range
Yes
Source 冬练三九之一 Recommend lcy   |   We have carefully selected several similar problems for you:  1591 1584 1082 1736 1347 
题解:这题的坐标没说明是整数啊.....坐标数据应该是规定整数的....是整数就是水题了... 如果是整数,可以利用gcd判断直线的点的个数 ,然后判断点的个数是否只是两个端点,如果只是两个端点,那么就是yes,否则是no即可。

AC代码:
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
int gcd ( int a , int b )
{
return b == 0 ? a:gcd ( b , a%b );
}
int l,sx,sy,px,py;
int main()
{
while (~scanf ("%d" ,&l ),l)
{
scanf ( "%d%d%d%d" , &sx , &sy , &px , &py );
int dx = abs ( sx - px );
int dy = abs ( sy - py );
int d = gcd ( dx , dy );
if ( abs ( px )> l || abs( py ) > l )
{
puts ("Out Of Range");
continue;
}
if (d ==1)
puts("Yes");
else puts("No");
}
return 0;
}