Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 339636 Accepted Submission(s): 106389
Problem Description
Calculate A + B.
Input
Each line will contain two integers A and B. Process to end of file.
Output
For each case, output A + B in one line.
Sample Input
1 1
Sample Output
2
杭电入门级水题,应该是大部分人在杭电做的第一道题吧,对于格式的掌握,也是从这里开始的,用三种方法:
c版本:
#include<stdio.h>
int main(){
int a,b;
while(scanf("%d%d",&a,&b )!=EOF)
printf("%d\n",a+b);
}
c++版本:
#include<iostream>
using namespace std;
int main()
{
int a,b;
while(cin>>a>>b)
cout<<a+b<<endl;
return ;
}
java版本:
import java.io.*;
import java.util.*;
class Main { //一定要是Main
public static void main(String[] args) {
Scanner cin = new Scanner(new BufferedInputStream(System.in));
int n,m;
while(cin.hasNext())
{
n = cin.nextInt();
m = cin.nextInt();
System.out.println(n+m);
}
}
}
至与三种方法的大小,自己提交过后一比就知道了。
杭电刷题之路从这里开始….