Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 5437 | Accepted: 3845 |
Description
The nth Triangular number, T(n) = 1 + … + n, is the sum of the first n integers. It is the number of points in a triangular array with n points on side. For example T(4):
X
X X
X X X
X X X X
Write a program to compute the weighted sum of triangular numbers:
W(n) = SUM[k = 1…n; k * T(k + 1)]
Input
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.
Each dataset consists of a single line of input containing a single integer n, (1 ≤ n ≤300), which is the number of points on a side of the triangle.
Output
For each dataset, output on a single line the dataset number (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum ,W(n), of triangular numbers for n.
Sample Input
4
3
4
5
10
Sample Output
1 3 45
2 4 105
3 5 210
4 10 2145
Source
#include <cstdio>
#include <cstdlib>
#include <cstring>
int T[310];
int W[310];
void init(){
int i, j;
memset(W, 0, sizeof(W));
T[1] = 1;
for (i = 2; i <= 304; i++){
T[i] = T[i - 1] + i;
}
W[1] = T[2];
for (i = 2; i<= 303; i++){
W[i] = W[i - 1] + i * T[i + 1];
}
}
int main(void){
int ii, casenum;
int n;
init();
scanf("%d", &casenum);
for (ii = 1; ii <= casenum; ii++){
scanf("%d", &n);
printf("%d %d %d\n", ii, n, W[n]);
}
return 0;
}