x+y与x-y结果已知求x,y题(Problem ID:1194)

时间:2021-11-25 01:17:08

题址:http://acm.hdu.edu.cn/showproblem.php?pid=1194


Problem Description

Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores.

Given the winning numbers for each type of bet, can you deduce the final scores?


Input
The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.


Output
For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers.


Sample Input
2
40 20
20 40


Sample Output
30 10

impossible


简单水题,已知两个数的和、差,求出两数。。


AC解答:(水题)
#include<stdio.h>

int main()
{
	int n,s,d,sum1,sum2;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d%d",&sum1,&sum2);
		if(sum1<sum2)
			printf("impossible\n");
		else if((sum1+sum2)%2!=0 || (sum1-sum2)%2!=0)
			printf("impossible\n");
		else
		{
			s=(sum1+sum2)/2;
			d=(sum1-sum2)/2;
			printf("%d %d\n",s,d);
		}
	}

	return 0;
}