Time Limit: 3 Sec Memory Limit: 128 MB
Submit: 1571 Solved: 675
Description
XLk觉得《上帝造题的七分钟》不太过瘾,于是有了第二部。
“第一分钟,X说,要有数列,于是便给定了一个正整数数列。
第二分钟,L说,要能修改,于是便有了对一段数中每个数都开平方(下取整)的操作。
第三分钟,k说,要能查询,于是便有了求一段数的和的操作。
第四分钟,彩虹喵说,要是noip难度,于是便有了数据范围。
第五分钟,诗人说,要有韵律,于是便有了时间限制和内存限制。
第六分钟,和雪说,要省点事,于是便有了保证运算过程中及最终结果均不超过64位有符号整数类型的表示范围的限制。
第七分钟,这道题终于造完了,然而,造题的神牛们再也不想写这道题的程序了。”
——《上帝造题的七分钟·第二部》
所以这个神圣的任务就交给你了。
Input
第一行一个整数n,代表数列中数的个数。
第二行n个正整数,表示初始状态下数列中的数。
第三行一个整数m,表示有m次操作。
接下来m行每行三个整数k,l,r,k=0表示给[l,r]中的每个数开平方(下取整),k=1表示询问[l,r]中各个数的和。
Output
对于询问操作,每行输出一个回答。
Sample Input
10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8
Sample Output
19
7
6
HINT
1:对于100%的数据,1<=n<=100000,1<=l<=r<=n,数列中的数大于0,且不超过1e12。
2:数据不保证L<=R 若L>R,请自行交换L,R,谢谢!
Source
Poetize4
两道题是一样的
3211: 花神游历各国
Time Limit: 5 Sec Memory Limit: 128 MB
Submit: 3927 Solved: 1428
[Submit][Status][Discuss]
Description
Input
Output
每次x=1时,每行一个整数,表示这次旅行的开心度
Sample Input
4
1 100 5 5
5
1 1 2
2 1 2
1 1 2
2 2 3
1 1 4
Sample Output
101
11
11
HINT
对于100%的数据, n ≤ 100000,m≤200000 ,data[i]非负且小于10^9
Source
SPOJ2713 gss4 数据已加强
直接线段树即可,如果这个区间的最大值大于了1才递归寻找,否则直接不再递归
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
const int MAXN = 1000010;
struct Tree{ long long sum, maxn; }tree[ MAXN * 4 ];
long long a[MAXN];
void pushup( int rt ) {
tree[rt].maxn = max( tree[ rt << 1 ].maxn, tree[ rt << 1 | 1 ].maxn );
tree[rt].sum = tree[ rt << 1 ].sum + tree[ rt << 1 | 1 ].sum;
}
void build( int l, int r, int rt ) {
if( l == r ) {
tree[rt].maxn = tree[rt].sum = a[l];
return;
}
int mid = ( l + r ) >> 1;
build( l, mid, rt << 1 );
build( mid + 1, r, rt << 1 | 1 );
pushup( rt );
}
void modify( int L, int R, int l, int r, int rt ) {
if( l == r ) { tree[rt].maxn = tree[rt].sum = (long long) sqrt( tree[rt].sum ); return ; }
int mid = ( l + r ) >> 1;
if( L <= mid && tree[ rt << 1 ].maxn > 1 ) modify( L, R, l, mid, rt << 1 );
if( R > mid && tree[ rt << 1 | 1 ].maxn > 1 ) modify( L, R, mid + 1, r, rt << 1 | 1 );
pushup( rt );
}
long long query( int L, int R, int l, int r, int rt ) {
if( L <= l && R >= r ) { return tree[rt].sum; }
int mid = ( l + r ) >> 1;
long long tmp = 0;
if( L <= mid ) tmp += query( L, R, l, mid, rt << 1 );
if( R > mid ) tmp += query( L, R, mid + 1, r, rt << 1 | 1 );
return tmp;
}
int main( ) { int n, m, opt, x, y;
scanf( "%d", &n );
for( register int i = 1; i <= n; i++ ) scanf( "%lld", &a[i] );
build( 1, n, 1 );
scanf( "%d", &m );
for( register int i = 1; i <= m; i++ ) {
scanf( "%d%d%d", &opt, &x, &y ); if( x > y ) swap( x, y );
if( opt == 2 ) modify( x, y, 1, n, 1 );
else printf( "%lld\n", query( x, y, 1, n, 1 ) );
}
return 0;
}