Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 5477 | Accepted: 3173 |
Description
Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers.
You should write a program that calculates the result and is able to find out who won the game.
Input
Output
(A1B1+A2B2+ ... +AHBH)mod M.
Sample Input
3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132
Sample Output
2
13195
13
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#define DD double
#define LL long long
#define INF 0x3f3f3f
#define MAX 1010
using namespace std;
int fun(int a,int b,int c)
{
int ans=1;
a=a%c;
while(b)
{
if(b&1)
ans=(a*ans)%c;
b=b/2;
a=(a*a)%c;
}
return ans;
}
int main()
{
int t,i,j;
int n,m,sum;
int x,y;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&m,&n);
sum=0;
for(i=1;i<=n;i++)
{
scanf("%d%d",&x,&y);
sum=fun(x,y,m)+sum;
}
printf("%d\n",sum%m);
}
return 0;
}