hdu 2716 Message Decowding

时间:2022-02-26 11:33:05

Message Decowding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 999    Accepted Submission(s): 468

Problem Description
The cows are thrilled because they've just learned about encrypting messages. They think they will be able to use secret messages to plot meetings with cows on other farms.

Cows are not known for their intelligence. Their encryption method is nothing like DES or BlowFish or any of those really good secret coding methods. No, they are using a simple substitution cipher.

The cows have a decryption key and a secret message. Help them decode it. The key looks like this:

yrwhsoujgcxqbativndfezmlpk

Which means that an 'a' in the secret message really means 'y'; a 'b' in the secret message really means 'r'; a 'c' decrypts to 'w'; and so on. Blanks are not encrypted; they are simply kept in place.

Input text is in upper or lower case, both decrypt using the same decryption key, keeping the appropriate case, of course.

 
Input
* Line 1: 26 lower case characters representing the decryption key

* Line 2: As many as 80 characters that are the message to be decoded

 
Output
* Line 1: A single line that is the decoded message. It should have the same length as the second line of input.
 
Sample Input
eydbkmiqugjxlvtzpnwohracsf
Kifq oua zarxa suar bti yaagrj fa xtfgrj
 
Sample Output
Jump the fence when you seeing me coming
 
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define MAX 1000
using namespace std;
int main()
{
char s[MAX];
char c;
while(scanf("%s",s)!=EOF)
{
getchar();
while(scanf("%c",&c)&&c!='\n')
{
if(c!=' ')
{
if(c>='A'&&c<='Z')
printf("%c",s[c-'A']-32);
else if(c>='a'&&c<='z')
printf("%c",s[c-'a']);
}
else
printf(" ");
}
printf("\n");
}
return 0;
}