uva133 The Dole Queue ( 约瑟夫环的模拟)

时间:2021-07-10 06:18:30

题目链接:

思路是:

相当于模拟约瑟夫环,仅仅只是是从顺逆时针同一时候进行的,然后就是顺逆时针走能够编写一个函数,仅仅只是是走的方向的标志变量相反。。还有就是为了(pos+flag+n-1)%n+1的妙用。。。

题目:

 The Dole Queue 

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing
inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts
from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person
and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three
numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise
official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0

Sample output

uva133 The Dole Queue ( 约瑟夫环的模拟) 4 uva133 The Dole Queue ( 约瑟夫环的模拟) 8, uva133 The Dole Queue ( 约瑟夫环的模拟) 9 uva133 The Dole Queue ( 约瑟夫环的模拟) 5, uva133 The Dole Queue ( 约瑟夫环的模拟) 3 uva133 The Dole Queue ( 约瑟夫环的模拟) 1, uva133 The Dole Queue ( 约瑟夫环的模拟) 2 uva133 The Dole Queue ( 约瑟夫环的模拟) 6, uva133 The Dole Queue ( 约瑟夫环的模拟) 10, uva133 The Dole Queue ( 约瑟夫环的模拟) 7

where uva133 The Dole Queue ( 约瑟夫环的模拟) represents a space.

代码为:

#include<cstdio>
#include<cstring>
const int maxn=25+10;
bool vis[maxn];
int n,k,m; int Move(int pos,int flag,int step)
{
for(int i=1;i<=step;i++)
{
do
{
pos=(pos+flag+n-1)%n+1;
}while(vis[pos]);
}
return pos;
} int main()
{
int left,p1,p2;
while(~scanf("%d%d%d",&n,&k,&m))
{
if(n==0&&k==0&&m==0) return 0;
memset(vis,false,sizeof(vis));
p1=n;
p2=1;
left=n;
while(left)
{
p1=Move(p1,1,k);
p2=Move(p2,-1,m);
printf("%3d",p1);
left--;
if(p1!=p2)
{
printf("%3d",p2);
left--;
}
vis[p1]=vis[p2]=1;
if(left)
printf(",");
else
printf("\n");
}
}
return 0;
}

Sample output

uva133 The Dole Queue ( 约瑟夫环的模拟) 4 uva133 The Dole Queue ( 约瑟夫环的模拟) 8, uva133 The Dole Queue ( 约瑟夫环的模拟) 9 uva133 The Dole Queue ( 约瑟夫环的模拟) 5, uva133 The Dole Queue ( 约瑟夫环的模拟) 3 uva133 The Dole Queue ( 约瑟夫环的模拟) 1, uva133 The Dole Queue ( 约瑟夫环的模拟) 2 uva133 The Dole Queue ( 约瑟夫环的模拟) 6, uva133 The Dole Queue ( 约瑟夫环的模拟) 10, uva133 The Dole Queue ( 约瑟夫环的模拟) 7