HDOJ 1024 Max Sum Plus Plus -- 动态规划

时间:2021-08-18 12:52:14

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=1024



Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.



Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define
a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).



Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im,
jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).



But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^
Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.

Process to the end of file.
Output
Output the maximal summation described above in one line.
Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
Sample Output
6
8
Recommend
We have carefully selected several similar problems for you:  1074 1025 1081 1080 1160



分析

设状态为 cur[i,j],表示前 j 项分为 i 段的最大和,且第 i 段必须包含 data[j],则状态转移方程如下:

cur[i,j] = max{cur[i,j − 1] + data[j],max{cur[i − 1,t] + data[j]}}, 其中i ≤ j ≤ n,i − 1 ≤ t < j

target = max{cur[m,j]}, 其中m ≤ j ≤ n


分为两种情况:

• 情况一,data[j] 包含在第 i 段之中,cur[i,j − 1] + data[j]。

• 情况二,data[j] 独立划分成为一段,max{cur[i − 1,t] + data[j]}。

观察上述两种情况可知 cur[i,j] 的值只和 cur[i,j-1] 和 cur[i-1,t] 这两个值相关,因此不需要二维数组,

可以用滚动数组,只需要两个一维数组,用 cur[j] 表示现阶段的最大值,即 cur[i,j − 1] + data[j],用

pre[j] 表示上一阶段的最大值,即 max{cur[i − 1,t] + data[j]}。
#include <stdio.h>
#include <stdlib.h>
#include <limits.h> int MaxSum(int * data, int m, int n){
int i, j, max_sum;
int * cur = (int *)calloc(n + 1, sizeof(int));
int * pre = (int *)calloc(n + 1, sizeof(int));
data = data - 1; //data下标从0开始, cur、pre下标从1开始,为使下标一致,data减1
for (i = 1; i <= m; ++i){
max_sum = INT_MIN;
for (j = i; j <= n; ++j){
if (cur[j - 1] < pre[j - 1])
cur[j] = pre[j - 1] + data[j];
else
cur[j] = cur[j - 1] + data[j];
pre[j - 1] = max_sum;
if (max_sum < cur[j])
max_sum = cur[j];
}
pre[j - 1] = max_sum;
}
free(cur);
free(pre);
return max_sum;
} int main(void){
int m, n, i, *data;
while (scanf("%d%d", &m, &n) != EOF){
data = (int *)malloc(sizeof(int) * n);
for (i=0; i<n; ++i){
scanf("%d", &data[i]);
}
printf ("%d\n", MaxSum(data, m, n));
free(data);
} return 0;
}

参考资料:ACM Cheat Sheet