每日一练ACM 2019.04.14

时间:2024-04-21 17:34:05

2019.4.14

第1001题:Sum Problem

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input
1
100
Sample Output
1

5050

解:

package Acm;

import java.util.Scanner;

public class test1 {
public static void main(String[] args)
{
Scanner input=new Scanner(System.in);
int a;
int b;
int sum = 0;
while(input.hasNext())
{
a=input.nextInt();
for(int i=1;i<=a;i++){
sum=sum+i; } System.out.println(sum);
//System.out.println();
sum=0;
} } }