PAT甲级练习1054. The Dominant Color (20)

时间:2023-02-04 20:21:51

1054. The Dominant Color (20)

时间限制100 ms
内存限制65536 kB
代码长度限制16000 B
判题程序Standard作者CHEN, Yue

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24
简单统计,用数组保存遍历通过,但是时间有点危险的感觉。。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <map>
#include <set>
#include <stack>
#include <string>
#include <string.h>

using namespace std;

const int MAX=2e7+10;

int n, m, a, cnt[MAX];

int main(){

scanf("%d%d", &n, &m);

for(int i=0; i<m; i++){
for(int j=0; j<n; j++){
scanf("%d", &a);
cnt[a]++;
}
}
int c = n * m;
for(int i=0; i<MAX; i++){
if(cnt[i]>c/2){
printf("%d\n", i);
break;
}
}

cin>>n;
return 0;
}

评测结果

时间 结果 得分 题目 语言 用时(ms) 内存(kB) 用户
2月26日 10:59 答案正确 20 1054 C++ (g++ 4.7.2) 93 384 shower

测试点

测试点 结果 用时(ms) 内存(kB) 得分/满分
0 答案正确 11 384 12/12
1 答案正确 4 384 2/2
2 答案正确 93 384 2/2
3 答案正确 7 384 2/2
4 答案正确 14 384 2/2