HDU 1686 Oulipo (可重叠匹配 KMP)

时间:2023-01-03 17:06:45

Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 21428    Accepted Submission(s): 8324


Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

 

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
 

 

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

 

Sample Input
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
 

 

Sample Output
1 3 0
 

 

Source
 

 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1358  3336  3746  2203  3068 
 
分析:
给你两个字符串,问你这两个字符串的可重叠的匹配次数是多少?
比如AZAZAZA匹配AZA是3次
需要注意的地方:
每次匹配成功之后j不要复位为0,而是需要复位到开始重叠的部分
即j=next[j]
code:
#include<cstdio>
#include<iostream>
#include<cstring>
#include<memory>
using namespace std;
char moban[1000005],wenben[1000005];
int next1[1000005];
int sum;
void getnext(char* s,int* next1,int m)
{
    next1[0]=0;
    next1[1]=0;
    for(int i=1;i<m;i++)
    {
        int j=next1[i];
        while(j&&s[i]!=s[j])
            j=next1[j];
        if(s[i]==s[j])
            next1[i+1]=j+1;
        else
            next1[i+1]=0;
    }
}
void kmp(char* ss,char* s,int* next1,int n)
{
    int m=strlen(s);
    getnext(s,next1,m);
    int j=0;
    for(int i=0;i<n;i++)
    {
        while(j&&s[j]!=ss[i])
            j=next1[j];
        if(s[j]==ss[i])
            j++;
        if(j==m)
        {
            sum++;
            //注意这里j不用复位为0,而是需要等于next[j],可重叠匹配匹配完之后需要跳到开始重叠的部分
            j=next1[j];//!!!
        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        sum=0;
        scanf("%s",moban);
        scanf("%s",wenben);
        int L=strlen(wenben);
        kmp(wenben,moban,next1,L);
        printf("%d\n",sum);
    }
    return 0;
}