【字符串入门专题1】 E - Cyclic Nacklace hdu3764 【kmp最小循环节应用】

时间:2023-01-03 16:47:58



Cyclic Nacklace



Problem DescriptionCC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:
【字符串入门专题1】 E - Cyclic Nacklace  hdu3764  【kmp最小循环节应用】

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
 
InputThe first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).
 
OutputFor each case, you are required to output the minimum count of pearls added to make a CharmBracelet. 
Sample Input
3
aaa
abca
abcde
 
Sample Output
0
2
5
 

题意:输出字符串至少循环两次所需要补全的字符数。

思路:KMP最小循环节的应用,hdu有个比较坑的地方是next数组定义为全局变量    的话会导致CE。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

#define N 110000
char s[N];
int Next[N];
int t;

void getNext(char s[],int Next[])
{
int j,k;
j = 0;
k = -1;
Next[0] = -1;
while(s[j]!='\0')
{
while(k!=-1&&s[k] != s[j])
k = Next[k];
Next[++j] = ++k;
}
return;
}

int kmp(char s[])
{
int l,k,ans,p,q,i;
ans = l = strlen(s);
i = Next[l];
while(i!=-1)
{
k = l - i;//最小循环节
p = l%k;//循环若干次后剩余的字符部分
q = (k-p)%k;//最少需要补充的字符数
if(l+q >= k*2)
ans = min(ans,q);
i = Next[i];//printf("%d\n",i);
}
return ans;
}
int main()
{
int t;
scanf("%d",&t);
while(t --)
{
getchar();
scanf("%s",s);
getNext(s,Next);
printf("%d\n",kmp(s));
}
return 0;
}


Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9593    Accepted Submission(s): 4105


Problem DescriptionCC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:
【字符串入门专题1】 E - Cyclic Nacklace  hdu3764  【kmp最小循环节应用】

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
 
InputThe first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).
 
OutputFor each case, you are required to output the minimum count of pearls added to make a CharmBracelet. 
Sample Input
3
aaa
abca
abcde
 
Sample Output
0
2
5