判断是不是一棵树

时间:2022-11-12 10:40:06

我们这里引用HDU1272做例子:

小希的迷宫

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 52059    Accepted Submission(s): 16244


Problem Description 上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。 
判断是不是一棵树
 
Input 输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。 
整个文件以两个-1结尾。
 
Output 对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。
 
Sample Input
6 8  5 3  5 2  6 4
5 6 0 0

8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0

3 8 6 8 6 4
5 3 5 6 5 2 0 0

-1 -1
 
Sample Output
Yes
Yes
No


这个题目实际上是让判断所给的是不是一棵无向树,我看网上也有很多做法,其实很简单

无向树就是节点数等于边数加一,即n=m+1.

看代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<cstring>
using namespace std;
typedef long long ll;
const int maxn = 1e5+5;
int vis[maxn];//记录有没有出现过
int pre[maxn];//记录父亲
int n,m;

int find(int x)
{
int r = x;
while(pre[r]!= r)
{
r = pre[r];
}
return r;
}

void push(int x,int y)
{
if(!vis[x]) n++;//这个点没出现过就在总数里加1
if(!vis[y]) n++;
vis[x] = vis[y] = 1;
int fx = find(x);
int fy = find(y);
if(fx!= fy)
pre[fx] = fy;
}

void init()//初始化
{
for(int i = 0;i< maxn;i++)
pre[i] = i;
n = 0;
m = 0;
memset(vis,0,sizeof(vis));
}

int main()
{
int a,b;
init();
while(~scanf("%d %d",&a,&b)&&(a!= -1||b!= -1))
{
if(!(a||b))
{
if(n == m+1||m == 0&&n == 0)//空树也是树嘛~
printf("Yes\n");
else
printf("No\n");
init();
continue;
}
m++;//边数加1
push(a,b);
}
}


这里我们再举一个有向树,引自POJ1308:

Is It A Tree?
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 33120   Accepted: 11232

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 
判断是不是一棵树

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6 0 0

8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0

3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

这是一个判断是不是有向树,他与无向树唯一区别就是,有一个点入度为0,其他所有点入度为1.

我们所以我们需要开一个数组记录入度

但是对于这道题还有几点注意:

1: 0 0 空树是一棵树
2: 1 1 0 0 不是树 不能自己指向自己
3: 1 2 1 2 0 0 不是树
4: 1 2 2 3 4 5 不是树  森林不算是树(主要是注意自己)
5: 1 2 2 3 3 4 4 5 5 6 6 7 7 8 8 9 9 1  注意 一个节点在指向自己的父亲或祖先 都是错误的 即 9-->1 错
6: 1 2 2 1 0 0 也是错误的
7:1 2 3 2 0 0 当然也不对,这是有向树

详看代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<cstring>
using namespace std;
typedef long long ll;
const int maxn = 1e5+5;
int vis[maxn];//记录有没有出现过
int pre[maxn];//记录父亲
int ind[maxn];//记录入度
int n,m;
int flag;

int find(int x)
{
int r = x;
while(pre[r]!= r)
{
r = pre[r];
}
return r;
}

void push(int x,int y)
{
if(!vis[x]) n++;
if(!vis[y]) n++;
vis[x] = vis[y] = 1;
int fx = find(x);
int fy = find(y);
if(fx!= fy)
pre[fx] = fy;
else
flag = 1;
}

void init()//初始化
{
for(int i = 0;i< maxn;i++)
pre[i] = i;
n = 0;
m = 0;
flag = 0;
memset(vis,0,sizeof(vis));
memset(ind,0,sizeof(ind));
}

int main()
{
init();
int a,b;
int cnt = 1;
while(~scanf("%d %d",&a,&b)&&(a!= -1||b!= -1))
{
if(!(a||b))
{
int num = 0;
for(int i = 1;i< maxn;i++)
{
if(vis[i]&&pre[i] == i)//只有出现过才可判断pre[i] == i这个条件
num++;
if(num> 1)
{
flag = 1;
break;
}
}
if(flag)
printf("Case %d is not a tree.\n",cnt++);
else
printf("Case %d is a tree.\n",cnt++);
init();
continue;
}
if(flag)
continue;
ind[b]++;
if(ind[b]> 1)
{
flag = 1;
continue;
}
m++;
push(a,b);
}
}


其实HDU 1325 Is It A Tree?也是这道题,不过没有POJ上判的严。

并查集