noip第3课作业

时间:2023-12-15 22:25:26

1.    求最大值

【问题描述】

输入三个数a,b,c,输出三个整数中的最大值

【样例输入】

10 20 30

【样例输出】

30

#include <iostream>
using namespace std;
int main(){
int a, b, c;
cin >> a >> b >> c;
if(a<b){
a=b;
}
if(a<c){
a=c;
}
cout << a << endl;
return ;
}

2.    苹果促销

【问题描述】

超市苹果打折促销,总重量如果不超过5斤,单价3元/斤,如果超过5斤,超过部分打八折;输入为所购买苹果的重量,输出为应付款的总额。

【样例输入1】

10

【样例输出1】

27

【样例输入2】

10.2

【样例输出2】

27.48

#include <iostream>
using namespace std;
int main(){
double m;
cin >> m;
if(m<=){
cout << *m << endl;
}else{
cout << +(m-)**0.8 << endl;
}
return ;
}

1.    判断数正负

【问题描述】

给定一个整数N,判断其正负。

输入:一个整数N(-109 <= N <= 109);

输出:如果N > 0, 输出positive;
如果N = 0, 输出zero;
如果N < 0, 输出negative

【样例输入】

1

【样例输出】

positive

#include <iostream>
using namespace std;
int main(){
int n;
cin >> n;
if(n>){
cout << "positive" << endl;
}else if(n==){
cout << "zero" << endl;
}else{
cout << "negative" << endl;
}
return ;
}

2.    奇偶ASCII值判断

【问题描述】

任意输入一个字符,判断其ASCII是否是奇数,若是,输出YES,否则,输出NO 例如,字符A的ASCII值是65,则输出YES,若输入字符B(ASCII值是66),则输出NO输入。

输入:输入一个字符。

输出:如果其ASCII值为奇数,则输出YES,否则,输出NO。

【样例输入】

A

【样例输出】

YES

#include <iostream>
using namespace std;
int main(){
char a;
cin >> a;
if(a%!=){
cout << "YES" << endl;
}else{
cout << "NO" << endl;
}
return ;
}

3.    整数大小比较

【问题描述】

输入两个整数,比较它们的大小。

输入:一行,包含两个整数x和y,中间用单个空格隔开,0 <= x < 2^32, -2^31 <= y < 2^31。

输出:一个字符。

若x > y,输出 > ;

若x = y,输出 = ;

若x < y,输出 < ;

【样例输入】

1000 100

【样例输出】

>

#include <iostream>
using namespace std;
int main(){
int x, y;
cin >> x >> y;
if(x>y){
cout << ">" << endl;
}else if(x==y){
cout << "=" << endl;
}else{
cout << "<" << endl;
}
return ;
}