HDU2222 Keywords Search(AC自动机入门)

时间:2022-09-12 23:57:28

Keywords Search

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 59294    Accepted Submission(s): 19490


Problem Description In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
 
Input First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
 
Output Print how many keywords are contained in the description.  
Sample Input
1
5
she
he
say
shr
her
yasherhs
 
Sample Output
3
 

这是一道AC自动机的类似于模板题了,只是在插入的时候在尾节点计数就行了。记得避免重复统计,需要在计数完之后清零

代码如下:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
#include<cstdio>
using namespace std;
const int maxx=10000*50+50;
struct AC{
int ch[maxx][27];
int val[maxx];
int fail[maxx];
int sz;int root;

int newnode(){
memset(ch[sz],-1,sizeof(ch[sz]));
val[sz++]=0;
return sz-1;
}

void init(){
sz=0;
root=newnode();
}

void insert(char str[]){
int len=strlen(str);
int now=root;
for(int i=0;i<len;i++)
{
if(ch[now][str[i]-'a']==-1)ch[now][str[i]-'a']=newnode();
now=ch[now][str[i]-'a'];
}
val[now]++;
}

void build(){
queue<int>q;
fail[root]=root;
for(int i=0;i<26;i++)
{
if(ch[root][i]==-1)ch[root][i]=root;
else {
fail[ch[root][i]]=root;
q.push(ch[root][i]);
}
}
while(!q.empty())
{
int now=q.front();q.pop();
for(int i=0;i<26;i++)
{
if(ch[now][i]==-1)ch[now][i]=ch[fail[now]][i];
else{
fail[ch[now][i]]=ch[fail[now]][i];
q.push(ch[now][i]);
}
}
}
}

int match(char str[]){
int len=strlen(str);
int now=root;
int res=0;
for(int i=0;i<len;i++)
{
now=ch[now][str[i]-'a'];
int temp=now;
while(temp!=root){
res+=val[temp];
val[temp]=0;//计数完之后清零
temp=fail[temp];
}
}return res;
}

}ac;


char s[1000000+50];
int n,m;
int main(){
while(scanf("%d",&n)!=EOF) {
while(n--){
scanf("%d",&m);
ac.init();
for(int i=0;i<m;i++)
{
scanf("%s",s);
ac.insert(s);
}
ac.build();
scanf("%s",s);
printf("%d\n",ac.match(s));
}
}
return 0;
}