1110 Complete Binary Tree (25 分)

时间:2022-08-26 23:53:51
1110 Complete Binary Tree (25 分)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a -will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

分析:判断是否是完全二叉树。先求根节点,可以设置一个数组child,如果输入过程中如果该结点被当做孩子节点那它一定不是根节点,输入完毕后从头开始遍历child数组,第一个是false的child[i]跳出,i就是根节点。那么如何判断是完全二叉树呢?这里提供两种方法。

1、层序遍历,每次把空节点也Push进队列中,完全二叉树层序遍历过程中,如果遇到空节点了,说明一定已经遍历完非空节点;而对非完全二叉树,如果遇到空节点了,后面还必定有非空节点。于是遍历过程中用一个变量统计已入队过的节点数量。1110 Complete Binary Tree (25 分)

2、递归求最大下标值,完全二叉树中,最大下标值=最大结点数(起始为1); 而非完全二叉树中,最大下标值>最大结点数

1110 Complete Binary Tree (25 分)

 代码分别如下:
 /**
 * Copyright(c)
 * All rights reserved.
 * Author : Mered1th
 * Date : 2019-02-26-21.04.42
 * Description : A1110
 */
 #include<cstdio>
 #include<cstring>
 #include<iostream>
 #include<cmath>
 #include<algorithm>
 #include<string>
 #include<unordered_set>
 #include<map>
 #include<vector>
 #include<set>
 #include<queue>
 using namespace std;
 struct Node{
     int l,r;
 }node[];
 ]={false};
 ,n;
 bool isCBT(int root){
     ;
     queue<int>q;
     q.push(root);
     while(!q.empty()){
         int top=q.front();
         q.pop();
         ){
             maxd=top;
             cnt++;
             q.push(node[top].l);
             q.push(node[top].r);
         }
         else{
             if(cnt==n) return true;
             else return false;
         }
     }
 }

 int main(){
 #ifdef ONLINE_JUDGE
 #else
     freopen("1.txt", "r", stdin);
 #endif
     cin>>n;
     string a,b;
     ;i<n;i++){
         cin>>a>>b;
         ]=='-'){
             node[i].l=-;
         }
         else{
             node[i].l=stoi(a);
             child[stoi(a)]=true;
         }
         ]=='-'){
             node[i].r=-;
         }
         else{
             node[i].r=stoi(b);
             child[stoi(b)]=true;
         }
     }
     int root;
     ;i<n;i++){
         if(child[i]==false){
             root=i;
             break;
         }
     }
     if(isCBT(root)) printf("YES %d",maxd);
     else printf("NO %d",root);
     ;
 }

这里利用了二叉树静态存储的性质,即父节点和叶子节点之间的关系。

 #include<cstdio>
 #include<cstring>
 #include<iostream>
 #include<cmath>
 #include<algorithm>
 #include<queue>
 using namespace std;
 struct node{
     int data;
     int l,r;
 }Node[];
 ,n;
 ]={false};
 /*void LayerOrder(int root){
     queue<int> Q;
     Q.push(root);
     while(!Q.empty()){
         int now=Q.front();
         Q.pop();
         if(Node[now].l!=-1){
             if(Node[now].r!=-1){
                 cnt++;
                 Q.push(Node[now].l);
             }
             else{
                 cnt++;
             }
         }
         if(Node[now].r!=-1){
             if(Node[now].l!=-1){
                 cnt++;
                 Q.push(Node[now].r);
             }
             else{
                 cnt++;
             }
         }
     }
 }
 */
 ,ans;
 void dfs(int root,int index){
     //求出最大下标值,如果下标值等于最大节点数-1则说明是完全二叉树,若大于最大结点数-1则非完全二叉树
     if(index>maxn){
         maxn=index;
         ans=root;
     }
     ) dfs(Node[root].l,index*);
     ) dfs(Node[root].r,index*+);
 }
 int main(){
 #ifdef ONLINE_JUDGE
 #else
     freopen("1.txt", "r", stdin);
 #endif
     cin>>n;
     string t1,t2;
     ;i<n;i++){
         cin>>t1>>t2;
         Node[i].data=i;
         if(t1=="-"){
             Node[i].l=-;
         }
         else{
             Node[i].l=stoi(t1);
             hashtable[stoi(t1)]=true;
         }
         if(t2=="-"){
             Node[i].r=-;
         }
         else{
             Node[i].r=stoi(t2);
             hashtable[stoi(t2)]=true;
         }
     }
     int i;
     ;i<n;i++){
         if(hashtable[i]==false) break;
     }
     dfs(i,);
     if(maxn==n){
         cout<<"YES "<<ans;
     }
     else{
         cout<<"NO "<<i;
     }
     ;
 }
 


1110 Complete Binary Tree (25 分)的更多相关文章

  1. 1110 Complete Binary Tree &lpar;25 分&rpar;

    Given a tree, you are supposed to tell if it is a complete binary tree. Input Specification: Each in ...

  2. 【PAT甲级】1110 Complete Binary Tree &lpar;25分&rpar;

    题意: 输入一个正整数N(<=20),代表结点个数(0~N-1),接着输入N行每行包括每个结点的左右子结点,'-'表示无该子结点,输出是否是一颗完全二叉树,是的话输出最后一个子结点否则输出根节点 ...

  3. &lbrack;二叉树建树&amp&semi;完全二叉树判断&rsqb; 1110&period; Complete Binary Tree &lpar;25&rpar;

    1110. Complete Binary Tree (25) Given a tree, you are supposed to tell if it is a complete binary tr ...

  4. 1110&period; Complete Binary Tree &lpar;25&rpar;

    Given a tree, you are supposed to tell if it is a complete binary tree. Input Specification: Each in ...

  5. PAT Advanced 1110 Complete Binary Tree &lpar;25&rpar; &lbrack;完全⼆叉树&rsqb;

    题目 Given a tree, you are supposed to tell if it is a complete binary tree. Input Specification: Each ...

  6. PAT甲题题解-1110&period; Complete Binary Tree &lpar;25&rpar;-(判断是否为完全二叉树)

    题意:判断一个节点为n的二叉树是否为完全二叉树.Yes输出完全二叉树的最后一个节点,No输出根节点. 建树,然后分别将该树与节点树为n的二叉树相比较,统计对应的节点个数,如果为n,则为完全二叉树,否则 ...

  7. PAT &lpar;Advanced Level&rpar; 1110&period; Complete Binary Tree &lpar;25&rpar;

    判断一棵二叉树是否完全二叉树. #include<cstdio> #include<cstring> #include<cmath> #include<vec ...

  8. PAT甲级——1110 Complete Binary Tree &lpar;完全二叉树&rpar;

    此文章同步发布在CSDN上:https://blog.csdn.net/weixin_44385565/article/details/90317830   1110 Complete Binary ...

  9. 1110 Complete Binary Tree

    1110 Complete Binary Tree (25)(25 分) Given a tree, you are supposed to tell if it is a complete bina ...

随机推荐

  1. AMO olap Test C&num; generate tsql and mdx

    通过AMO访问online的cube,生成等值的TSql和mdx 自动生成等值的TSQL和MDX进行Cube测试.其中难度比较大的部分是拼接TSQL. 暂时不处理calculations,只除理met ...

  2. Notepad&plus;&plus;中NppExec的使用之一:基本用法

    一直用NPP,很长时间了,最近才学习它的各种插件,这篇文章是根据NppExec的用户指南写的.很多地方是翻译的,但不全是翻译,同时也有些东西没有翻译. 一.何为NppExec 简单的说,这个插件可以让 ...

  3. 单点登录&lpar;iwantmoon&period;com出品&rpar;

    早年便听到单点登录,一直因为感觉很简单,就没有动手去弄,正好现在公司有要求,那么OK,直接做了一个单机版的单点登录. 原理,可以参考SSO. Now,我们来看看我的实现吧.看下图 我们平时所做的登录, ...

  4. cocos2d-x3&period;0-结合TH脚本引擎

    近期自己在研究手机游戏开发,呵呵.引擎就选择了cocos2d-x,略微看了下感觉好像非常不错的样子. 写个一般的游戏,全然能够了.工作量也不会非常大,相对来说开发非常轻松了. 在脚本引擎的选择其中,当 ...

  5. Volatile vs&period; Interlocked vs&period; lock

    今天在*上看到一个关于Volatile, Interlock, Lock的问题,发现回答的特别好,所以就想到把它翻译一下, 希望给那些对它们有疑惑的人提供点帮助 :假设有一个类 ...

  6. qingshow &OpenCurlyDoubleQuote;不积跬步无以至千里,不积小流无以成江海”。--荀子《劝学篇》 用tomcat&plus;花生壳搭建自己的web服务器&plus;域名(参考)

    链接地址:http://www.blogjava.net/qingshow/archive/2010/01/17/309846.html 用tomcat搭建web服务器 目标:免费拥有自己的网站及域名 ...

  7. HTML5 CSS3 诱人的实例 :canvas 模拟实现电子彩票刮刮乐

    转载请标明出处:http://blog.csdn.net/lmj623565791/article/details/34089553 今天给大家带来一个刮刮乐的小例子~基于HTML5 canvas的, ...

  8. python学习笔记(8)--random库的使用

    伪随机数:采用梅森旋转算法生成的伪随机序列中元素 使用random库 一.基本随机函数 随机数需要一个种子,依据这个种子通过梅森旋转算法产生固定序列的随机数.seed(a=None)  初始化给定的随 ...

  9. final关键字的用法

    final关键字的作用 1.被final修饰的类不能被继承 报错信息:cannot inherit from final 'com.dajia.test.Animal' 2.被final修饰的方法不能 ...

  10. 激活win10专业版

    每180天激活一次