UVa 100 - The 3n + 1 problem(函数循环长度)

时间:2022-01-19 21:08:08

题目来源:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=3&page=show_problem&problem=36

 The 3n + 1 problem 

Background

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

The Problem

Consider the following algorithm:


1. input n

2. print n

3. if n = 1 then STOP

4. if n is odd then UVa 100 - The 3n + 1 problem(函数循环长度)

5. else UVa 100 - The 3n + 1 problem(函数循环长度)

6. GOTO 2

Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given nthis is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

The Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

You can assume that no operation overflows a 32-bit integer.

The Output

For each pair of input integers i and j you should output ij, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

Sample Input

1 10
100 200
201 210
900 1000

Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174 解题分析:根据题目描述需要在给定的区间里面找出循环长度最长的。
首先明确这个函数是什么?
函数f(n)为分段函数:当n为奇数时f(n)=3n+1;当n为偶数时f(n)=n/2;
然后需要明白什么是循环长度?
就是当f(n)进行多少次内部运算之后才能得到 1。
最后就是代码:
(1)写出函数计算循环长度;
(2)由于题目中没有说明i,j的大小关系,同时题目要求输出的i,j顺序和输入的i,j顺序要相同,所以可以有两种方法:
第一种:输入i,j之后直接输出,然后计算最长循环长度;
第二种:输入i,j之后,声明新的变量来使用,计算过程中完全不影响i,j的值。最后输出时i,j直接输出即可。
已过代码:
 #include <bits/stdc++.h>

 using namespace std;

 int length(int n) {
int len=;
while(n!=)
{
if(n%==)
n=*n+;
else
n=n/;
len=len+;
}
return len;
} int main(void) {
int start,over;
int s,o;
int ans;
while(~scanf("%d%d",&start,&over))
{
ans=;
s=start, o=over ;
if(s>o) swap(s,o);
for(int i=s;i<=o;i++)
{
int len=length(i);
ans=max(ans,len);
}
printf("%d %d %d\n",start,over,ans);
}
}