UVa 11729 - Commando War(贪心)

时间:2022-05-05 01:52:40

“Waiting for orders we held in the wood, word from the front never came

By evening the sound of the gunfire was miles away

Ah softly we moved through the shadows, slip away through the trees

Crossing their lines in the mists in the fields on our hands and our knees

And all that I ever, was able to see

The fire in the air, glowing red, silhouetting the smoke on the breeze”

There is a war and it doesn’t look very promising for your country. Now it’s time to act. You

have a commando squad at your disposal and planning an ambush on an important enemy camp

located nearby. You have N soldiers in your squad. In your master-plan, every single soldier has a

unique responsibility and you don’t want any of your soldier to know the plan for other soldiers so that

everyone can focus on his task only. In order to enforce this, you brief every individual soldier about

his tasks separately and just before sending him to the battlefield. You know that every single soldier

needs a certain amount of time to execute his job. You also know very clearly how much time you

need to brief every single soldier. Being anxious to finish the total operation as soon as possible, you

need to find an order of briefing your soldiers that will minimize the time necessary for all the soldiers

to complete their tasks. You may assume that, no soldier has a plan that depends on the tasks of his

fellows. In other words, once a soldier begins a task, he can finish it without the necessity of pausing

in between.

Input

There will be multiple test cases in the input file. Every test case starts with an integer N (1 ≤

N ≤ 1000), denoting the number of soldiers. Each of the following N lines describe a soldier with two

integers B (1 ≤ B ≤ 10000) & J (1 ≤ J ≤ 10000). B seconds are needed to brief the soldier while

completing his job needs J seconds. The end of input will be denoted by a case with N = 0. This case

should not be processed.

Output

For each test case, print a line in the format, ‘Case X: Y ’, where X is the case number & Y is the

total number of seconds counted from the start of your first briefing till the completion of all jobs.

Sample Input

3

2 5

3 2

2 1

3

3 3

4 4

5 5

0

Sample Output

Case 1: 8

Case 2: 15

题意:

你有n个部下,每个部下需要完成一项任务。第i个部下需要你花B(i)分钟交代任务,

然后他就会立刻独立的、无间断的执行J(i)分钟后完成任务。

你需要选择交代任务的顺序,使得所有任务尽早执行完毕(即最后一个执行完的任务应尽早结束)。

注意:不能同时给2个或以上的部下交代任务,但部下们可以同时执行他们各自的任务。

输入第一行为n,n为部下的个数。

接下来的n行为B和J。

当n为0时,输入结束。

分析:

执行时间较长的任务需要先交代,

于是,我们可以想到这样一个贪心算法:

按照J从小到大的顺序给各个任务排序,然后依次交代。

package cn.hncu.UVa;

import java.util.Arrays;
import java.util.Comparator;
import java.util.Scanner; /**
*
* @author 陈浩翔
*
* 2016-4-25
*/
public class P11729 { public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int k=0;
while(sc.hasNext()){
k++;
int n =sc.nextInt();
if(n==0){
break;
}
Bj bj[] = new Bj[n];
for(int i=0;i<n;i++){
bj[i]=new Bj();
bj[i].b = sc.nextInt();
bj[i].j = sc.nextInt();
}
sort(bj);
int s=0;
int ans =0;
for(int i=0;i<n;i++){
s = s+bj[i].b;//当前任务的开始执行时间,也就是吩咐完后的时间
ans = Math.max(ans, s+bj[i].j);//更新用户任务执行完毕时的最晚时间
}
System.out.println("Case "+k+": "+ans);
}
} private static void sort(Bj[] bj) {
Arrays.sort(bj, new Comparator<Bj>() {
@Override
public int compare(Bj o1, Bj o2) {
if(o1.j<o2.j){
return 1;
}
return -1;
}
});
}
} class Bj{
public int b;
public int j;
}

UVa 11729 - Commando War(贪心)的更多相关文章

  1. Uva 11729 Commando War (简单贪心)

    Uva 11729  Commando War (简单贪心) There is a war and it doesn't look very promising for your country. N ...

  2. 贪心 UVA 11729 Commando War

    题目传送门 /* 贪心:按照执行时间长的优先来排序 */ #include <cstdio> #include <algorithm> #include <iostrea ...

  3. UVA 11729 - Commando War(贪心 相邻交换法)

    Commando War There is a war and it doesn't look very promising for your country. Now it's time to ac ...

  4. &lbrack;ACM&lowbar;水题&rsqb; UVA 11729 Commando War &lbrack;不可同时交代任务 可同时执行 最短完成全部时间 贪心&rsqb;

    There is a war and it doesn't look very promising for your country. Now it's time to act. You have a ...

  5. UVa 11729 Commando War 【贪心】

    题意:有n个部下,交待每个部下完成他相应的任务需要bi的时间,然后完成这项任务需要ji的时间, 选择交待任务的顺序,使得总的花费的时间最少 因为不管怎么样,交待所需要的n*bi的时间都是要花费的, 然 ...

  6. UVa 11729 - Commando War

    [题目翻译]: 题目分析:因为任务是可以并行的执行,所以直觉上是花费时间长的任务优先去部署.但是这到题目还给你交待任务的时间,所以容易让人想多了. 不管有没有交待任务的时间,对于任务x和y,只可能有两 ...

  7. UVa 11729 Commando War 突击战

    你有 n 个部下,每个部下需要完成一个任务.第 i 个部下需要你花 Bi 分钟交待任务,然后他会立刻独立地.无间断地执行 Ji 分钟后完成任务.你需要选择交待任务的顺序,使得所有任务尽早执行完毕(即最 ...

  8. cogs 1446&period; &lbrack;Commando War&comma;Uva 11729&rsqb;突击战

    1446. [Commando War,Uva 11729]突击战 ★   输入文件:commando.in   输出文件:commando.out   简单对比时间限制:1 s   内存限制:64 ...

  9. Commando War

    Commando War“Waiting for orders we held in the wood, word from the front never cameBy evening the so ...

随机推荐

  1. 最大流加强 dinic&plus;当前弧优化

    qyy开始练习网络流啦 , 啊 ,蒟蒻只会套版 ,很裸的题 , 我连题都不想发了 ,可以参考我的代码(虽然我也是看的别人的 #include <iostream> #include &lt ...

  2. redis实现分布式可重入锁

    利用redis可以实现分布式锁,demo如下: /** * 保存每个线程独有的token */ private static ThreadLocal<String> tokenMap = ...

  3. Dynamics CRM中一个查找字段引发的【血案】

    摘要: 本人微信和易信公众号: 微软动态CRM专家罗勇 ,回复267或者20180311可方便获取本文,同时可以在第一间得到我发布的最新的博文信息,follow me!我的网站是 www.luoyon ...

  4. &lbrack;HNOI2013&rsqb;消毒

    题目大意: 网址:https://www.luogu.org/problemnew/show/3231 大意:a×b×c的三维空间里有a×b×c个点(x,y,z),其中有些点需要被消除. 消除的方法为 ...

  5. JVM内存管理概述与android内存泄露分析

    一.内存划分 将内存划分为六大部分,分别是PC寄存器.JAVA虚拟机栈.JAVA堆.方法区.运行时常量池以及本地方法栈. 1.PC寄存器(线程独有):全称是程序计数寄存器,它记载着每一个线程当前运行的 ...

  6. 【Java并发&period;5】基础构建模块

    本章会介绍一些最有用的并发构建模块,有丶东西(最后一小节,纯干货). 5.1 同步容器类 同步容器类包括 Vector 和 Hashtable ,这些类实现线程安全的方式是:将它们的状态封装起来,并对 ...

  7. Sublime Text 查找时排除指定的文件夹或文件

    Sublime Text 查找时排除指定的文件夹或文件 Ctrl + Shift + F这组快捷键可以调出 Sublime Text 的查找替换窗口,里边有一栏 Where,可以做一些高级设置:d:\ ...

  8. wget和curl方式下载JDK

    有时候我们需要在Linux服务器上安装Oracle JDK,这时候我们发现直接复制网页上面的地址是不能下载的 以下载jdk-8u101-linux-i586.tar.gz为例,右键查看到的地址为htt ...

  9. 解题:ZJOI 2015 幻想乡战略游戏

    题面 神**所有点都爆int,我还以为我写出什么大锅了,不开long long见祖宗... 动态点分治利用点分树树高不超过log的性质,我们对每个点维护一个子树和,一个点分树子树和,一个点分树上父亲的 ...

  10. 如何开启mysql5&period;5的客户端服务 命令行打开方法

    MySQL分为两个部分,服务器端和客户端,只有服务器端的服务开启后,才可以通过客户端登录到MySQL数据库.这里介绍如何用命令行方式开启mysql的客户端服务. 在计算机上安装好mysql软件   我 ...