最近学习路由器重分布、策略路由,用GNS3做了以下实验,看拓扑:
简要说明:
1、三层交换机上划分3个vlan,建立对应的vlan网关,创建默认路由指向 192.168.4.253 (R3 的 f 0/0)
2、路由器R3、R4通过两根串口线相连,同时启用OSPF,发布各自的直连网段
3、路由器R3上对192.168.1.0 、192.168.2.0、 192.168.3.0三个网段创建静态路由,指向192.168.4.254 (S3的f 0/0)
4、在路由器R3的ospf进程里重发布静态路由,使得R4能学习到R3的静态路由。
5、完成以上步骤后,全网互通。tracer发现PC1访问PC4走的是200.1.1.0线路;PC2访问PC4走的是192.168.5.0线路。因此在R3的f 0/0上应用策略路由,使得PC1访问PC4走192.168.5.0线路,PC2访问PC4走200.1.1.0线路。
实验效果:
============
两台路由器参考配置:
R3#show run
version 12.4
hostname R3
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.4.253 255.255.255.0
ip policy route-map mypbr //应用策略路由mypbr
duplex auto
speed auto
!
!
interface Serial0/1
ip address 192.168.5.1 255.255.255.0
clock rate 2000000
!
interface Serial0/2
ip address 200.1.1.1 255.255.255.0
clock rate 2000000
!
router ospf 1
log-adjacency-changes
redistribute static subnets //重发布静态路由
network 192.168.4.0 0.0.0.255 area 0
network 192.168.5.0 0.0.0.255 area 0
network 200.1.1.0 0.0.0.255 area 0
!
ip forward-protocol nd
ip route 192.168.1.0 255.255.255.0 192.168.4.254
ip route 192.168.2.0 255.255.255.0 192.168.4.254
ip route 192.168.3.0 255.255.255.0 192.168.4.254
!
!
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 2 permit 192.168.2.0 0.0.0.255
!
!
!
route-map mypbr permit 10 //建立路由映射,序列10
match ip address 1 //匹配ACL 1
set ip next-hop 192.168.5.254 //指定下一跳
!
route-map mypbr permit 20
match ip address 2
set ip next-hop 200.1.1.254
!
end
==============================
R4#
R4#show run
!
!
hostname R4
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 222.1.1.254 255.255.255.0
duplex auto
speed auto
!
!
interface Serial0/1
ip address 192.168.5.254 255.255.255.0
clock rate 64000
!
interface Serial0/2
ip address 200.1.1.254 255.255.255.0
clock rate 64000
!
!
router ospf 1
log-adjacency-changes
network 192.168.5.0 0.0.0.255 area 0
network 200.1.1.0 0.0.0.255 area 0
network 222.1.1.0 0.0.0.255 area 0
!
!
end
===================================
说明及疑问:
策略路由配置部分参考了该页面: http://lgzeng2360.blog.51cto.com/275998/160787
疑问及思考:1、这种双线连接两个路由器的情况,在实际工程中有实际用途吗?
2、本实验中,策略路由只考虑了数据包从左至右的情况,还要考虑从右至左的情况吗?
由于没有实际的网络工程经验,欢迎探讨、指正。能提供策略路由实用的,简单的例子就更好了:)
本文出自 “懒人天地” 博客,请务必保留此出处http://lazyman.blog.51cto.com/745747/690463