POJ 1236 tarjan

时间:2022-03-29 21:02:48
Network of Schools
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 19613   Accepted: 7725

Description

A number of schools are connected to a computer network. Agreements have been developed among those schools: each school maintains a list of schools to which it distributes software (the “receiving schools”). Note that if B is in the distribution list of school A, then A does not necessarily appear in the list of school B 
You are to write a program that computes the minimal number of schools that must receive a copy of the new software in order for the software to reach all schools in the network according to the agreement (Subtask A). As a further task, we want to ensure that by sending the copy of new software to an arbitrary school, this software will reach all schools in the network. To achieve this goal we may have to extend the lists of receivers by new members. Compute the minimal number of extensions that have to be made so that whatever school we send the new software to, it will reach all other schools (Subtask B). One extension means introducing one new member into the list of receivers of one school. 

Input

The first line contains an integer N: the number of schools in the network (2 <= N <= 100). The schools are identified by the first N positive integers. Each of the next N lines describes a list of receivers. The line i+1 contains the identifiers of the receivers of school i. Each list ends with a 0. An empty list contains a 0 alone in the line.

Output

Your program should write two lines to the standard output. The first line should contain one positive integer: the solution of subtask A. The second line should contain the solution of subtask B.

Sample Input

5
2 4 3 0
4 5 0
0
0
1 0

Sample Output

1
2

Source

思路:求一个有向图从几个点出发可以遍历整个图、以及至少加几条边使整张图强联通。

缩点以后,显然入度为0的点的个数就是第一问的答案。 
然后第二问答案显然是入度为0和出度为0的个数的最大值,即出入度为0的点间连条边就可以了。

代码:

 #include <cstdio>
 #include <cstring>
 #include <algorithm>
 using namespace std;
 #define ms(a, b) memset(a, b, sizeof(a))
 , M = ;
 int h[N], p[M], a[M], fa[N], out[N], in[N], dfn[N], low[N];
 int scc, top, ts, cnt, sta[N], insta[N];
 void add(int x, int y) { p[++cnt] = h[x]; a[cnt] = y; h[x] = cnt; }

 void tarjan(int u) {
     int i;
     dfn[u] = low[u] = ++ts;
     sta[++top] = u; insta[u] = ;
     for (i = h[u]; i; i = p[i])
         if (!dfn[a[i]]) {
             tarjan(a[i]);
             low[u] = min(low[u], low[a[i]]);
         } else if (insta[a[i]])
             low[u] = min(low[u], dfn[a[i]]);
     if (dfn[u] == low[u]) {
         ++scc;
         do {
             i = sta[top--];
             insta[i] = ;
             fa[i] = scc;
         } while (i != u);
     }
 }

 int main() {
     int i, j, n, m, x, b;

     while (scanf("%d", &n) != EOF) {
         ms(dfn, ); ms(); ms(h, ); ms();
         ts = cnt = top = scc = ;
         ; i <= n; ++i)
             while (scanf("%d", &x) && x) add(i, x);
         ; i <= n; ++i)
             if (!dfn[i]) tarjan(i);
         ; i <= n; ++i)
             for (j = h[i]; j; j = p[j])
                 if (fa[i] != fa[a[j]])
                     ++out[fa[i]], ++in[fa[a[j]]];
         ,a2=;
         ; i <= scc; ++i) {
             if (!out[i]) ++a1;
             if (!in[i])  ++a2;
         }
         ) puts("1\n0");
         else printf("%d\n%d\n", a2, max(a1, a2));
     }
     ;
 }