Max Sum—hdu1003(简单DP) 标签: dp 2016-05-05 20:51 92人阅读 评论(0)

时间:2022-03-13 16:03:57

Max Sum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 207989 Accepted Submission(s): 48681

Problem Description

Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2

5 6 -1 5 4 -7

7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:

14 1 4

Case 2:

7 1 6


本题用DP求最大子序列,用l和r标记下标

用一个b记录子序列大小,若为负,则对整个序列起减小作用,不取,

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
using namespace std; int main()
{
int o,n,a[100005],b,mx,l,r,l1,r1;
while(~scanf("%d",&o))
{
int t=0;
int q=o;
while(o--)
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);
b=0;
mx=-1001;
l=r=l1=r1=1; for(int i=1;i<=n;i++)
{
if(b<0)
{
l=i;
r=i;
b=a[i];
}
else
{
r=i;
b+=a[i];
}
if(mx<b)
{
l1=l;
r1=r;
mx=b;
}
}
printf("Case %d:\n",++t);
printf("%d %d %d\n",mx,l1,r1);
if(t!=q)
printf("\n");
}
}
return 0;
}