POJ3624 Charm Bracelet(01背包~~简单DP~~)

时间:2022-12-03 04:27:38

Charm Bracelet
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 27287   Accepted: 12283

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

第一天开始看动态规划DP,先从背包问题开始,找了背包九讲一点一点往下看,发现以前觉得怎么都绕不过来的DP,只要弄清楚转移方程,也并没有想象中那么难嘛 (*^-^*) 今天一共敲了四道简单的背包题,就因为忘了把freopen注释掉,wa了好几次。。。。。。代码习惯经常被队友吐槽,正在慢慢改╮(╯▽╰)╭

POJ3624就是一个简单的01背包~~

/*01背包*/
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;

int w[4000],d[4000],dp[13000];

int main()
{
//freopen("in.txt","r",stdin);
int n,m;
while(scanf("%d%d",&n,&m) != EOF)
{
memset(dp,0,sizeof(dp));
for(int i = 0; i < n; i++)
{
scanf("%d%d", &w[i], &d[i]);
for(int j = m; j >= 0; j--)//01背包,从m到0循环;完全背包反之。
if(j>=w[i])
dp[j]=max(dp[j],dp[j-w[i]]+d[i]);
}
printf("%d\n",dp[m]);
}
}