POJ 2533 Longest Ordered Subsequence 最长递增序列

时间:2023-03-09 13:05:38
POJ 2533 Longest Ordered Subsequence 最长递增序列

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion

题目大意:求最长递增序列的长度

题解:题解写在另一篇

--------http://www.cnblogs.com/Noevon/p/5685975.html

#include <stdio.h>
], a[];
int main()
{
    int i, j, n, max;
    scanf("%d", &n);
    ;i<=n;i++)
        scanf("%d", &a[i]);
    a[] = ;
    ;i<=n;i++)
    {
        ,j=i;j>=;j--)
            if(a[i]>a[j]&&max<b[j])
                max=b[j];
        b[i] = max+;
    }
    ,i=;i<=n;i++)
        if(max < b[i])
        max = b[i];
        printf("%d\n", max);

        ;
}

//