cigarettes

时间:2023-03-09 20:33:47
cigarettes

描述

Tom has many cigarettes. We hypothesized that he has n cigarettes and smokes them

one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette. 
Now,do you know how many cigarettes can Tom has?

输入
First input is a single line,it's n and stands for there are n testdata.then there are n lines ,each line contains two integer numbers giving the values of n and k.
输出
For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.
样例输入
3
4 3
10 3
100 5
样例输出
5
14
124
 import java.util.Arrays;
import java.util.Scanner; public class Main {
public static void main(String[] args) {
Scanner scanner=new Scanner(System.in);
int T;
int n;
int k;
int count;
int temp; T=scanner.nextInt(); while(true){
if(T==0)
break;
T--; n=scanner.nextInt();
k=scanner.nextInt(); count=0;
temp=n;
while(true){
if(n>=k){
n=n-k+1;
count++;
}
else
break;
}
System.out.println(count+temp);
}
}
}