IP Address 分类: POJ 2015-06-12 19:34 12人阅读 评论(0) 收藏

时间:2023-03-09 20:03:57
IP Address                                                       分类:            POJ             2015-06-12 19:34    12人阅读    评论(0)    收藏
IP Address
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 19125   Accepted: 11053

Description

Suppose you are reading byte streams from any device, representing IP addresses. Your task is to convert a 32 characters long sequence of '1s' and '0s' (bits) to a dotted decimal format. A dotted decimal format for an IP address
is form by grouping 8 bits at a time and converting the binary representation to decimal representation. Any 8 bits is a valid part of an IP address. To convert binary numbers to decimal numbers remember that both are positional numerical systems, where the
first 8 positions of the binary systems are:
27   26  25  24  23   22  21  20 

128 64  32  16  8   4   2   1 

Input

The input will have a number N (1<=N<=9) in its first line representing the number of streams to convert. N lines will follow.

Output

The output must have N lines with a doted decimal IP address. A dotted decimal IP address is formed by grouping 8 bit at the time and converting the binary representation to decimal representation.

Sample Input

4
00000000000000000000000000000000
00000011100000001111111111111111
11001011100001001110010110000000
01010000000100000000000000000001

Sample Output

0.0.0.0
3.128.255.255
203.132.229.128
80.16.0.1
二进制转化
#include <cstdio>
#include <string.h>
#include <cmath>
#include <iostream>
#include <algorithm>
#define WW freopen("output.txt","w",stdout)
using namespace std;
int main()
{
char s[100];
int T;
scanf("%d",&T);
while(T--)
{
scanf("%s",s);
int len=strlen(s);
int a[5];
int sum=0,ans=1;
for(int j=1,i=len-1;i>=0;i--,j++)
{
if(j%8)
{
sum=(s[i]-'0')*ans+sum;
ans*=2;
}
else
{
sum=(s[i]-'0')*ans+sum;
ans=1;
a[j/8]=sum;
sum=0;
}
}
printf("%d.%d.%d.%d\n",a[4],a[3],a[2],a[1]);
}
return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。