HDU5099——Comparison of Android versions(简单题)(2014上海邀请赛重现)

时间:2023-03-09 22:58:11
HDU5099——Comparison of Android versions(简单题)(2014上海邀请赛重现)

Comparison of Android versions
Problem Description
As an Android developer, itˇs really not easy to figure out a newer version of two kernels, because Android is updated so frequently and has many branches. Fortunately, Google identifies individual builds with a short build code, e.g. FRF85B.
The first letter is the code name of the release family, e.g. F is Froyo. The code names are ordered alphabetically. The latest code name is K (KitKat).
The second letter is a branch code that allows Google to identify the exact code branch that the build was made from, and R is by convention the primary release branch.
The next letter and two digits are a date code. The letter counts quarters, with A being Q1 2009. Therefore, F is Q2 2010. The two digits count days within the quarter, so F85 is June 24 2010.
Finally, the last letter identifies individual versions related to the same date code, sequentially starting with A; A is actually implicit and usually omitted for brevity.
Please develop a program to compare two Android build numbers.
Input
The first line is an integer n (1 <= n <= 2000), which indicates how many test cases need to process.
Each test case consists of a single line containing two build numbers, separated by a space character.
Output
For each test case, output a single line starting with ¨Case #: 〃 (# means the number of the test case). Then, output the result of release comparison as follows:
● Print "<" if the release of the first build number is lower than the second one;
● Print "=" if the release of the first build number is same as he second one;
● Print ">" if the release of the first build number is higher than the second one.
Continue to output the result of date comparison as follows:
● Print "<" if the date of the first build number is lower than the second one;
● Print "=" if the date of the first build number is same as he second one;
● Print ">" if the date of the first build number is higher than the second one.
If two builds are not in the same code branch, just compare the date code; if they are in the same code branch, compare the date code together with the individual version.
Sample Input
2
FRF85B EPF21B
KTU84L KTU84M
Sample Output
Case 1: > >
Case 2: = <

题目大意&解题思路:

    1、比较两个字符串的第一个字母的大小.
    2、如果两个字符串的第二个字母不同就比较接下来的三个字母的大小.
          如果两个字符串的第二个字母相同就比较剩余的四个字母.

    PS:英语好读懂题就不难。TT

Code:

 /*************************************************************************
> File Name: shanghai_1010.cpp
> Author: Enumz
> Mail: 369372123@qq.com
> Created Time: 2014年11月02日 星期日 13时43分08秒
************************************************************************/ #include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<list>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
#include<cmath>
#include<bitset>
#include<climits>
#define MAXN 100000
using namespace std;
char str1[],str2[];
int main()
{
int T;
cin>>T;
int times=;
while (T--)
{
cin>>str1>>str2;
printf("Case %d:",times++);
char tmp1[]={},tmp2[]={};
tmp1[]=str1[];
tmp2[]=str2[];
if (strcmp(tmp1,tmp2)>)
printf(" >");
else if (strcmp(tmp1,tmp2)<)
printf(" <");
else printf(" =");
tmp1[]=str1[];
tmp2[]=str2[];
if (strcmp(tmp2,tmp1)!=)
{
str1[]=,str2[]=;
if (strcmp(str1+,str2+)>)
printf(" >\n");
else if( strcmp(str1+,str2+)<)
printf(" <\n");
else
printf(" =\n");
}
else
{
if (strcmp(str1+,str2+)>)
printf(" >\n");
else if (strcmp(str1+,str2+)<)
printf(" <\n");
else
printf(" =\n");
}
}
return ;
}