ACM题目————A simple problem

时间:2023-03-09 16:37:39
ACM题目————A simple problem

Description

Zty很痴迷数学问题.。一天,yifenfei出了个数学题想难倒他,让他回答1 / n。但Zty却回答不了^_^. 请大家编程帮助他.

Input

第一行整数T,表示测试组数。后面T行,每行一个整数 n (1<=|n|<=10^5).

Output

输出1/n. (是循环小数的,只输出第一个循环节).

Sample Input

4
2
3
7
168

Sample Output

0.5
0.3
0.142857
0.005952380

和我名字那么相近的题目,当然要AC了!

//如果余数出现重复就表示有循环节
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <iterator>
#include <deque>
#include <string>
#include <string.h>
#include <vector>
#include <stack>
#include <ctype.h>
#include <queue>
#include <math.h>
#include <stdlib.h>
#include <map>
#include <set>
#include <time.h>
#include <bitset>
#include <list> using namespace std; int f[100000];
int flag[100000];
int main()
{
int t,m,y,cnt,n,i;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
if(n<0) //如果是负数
{
printf("-");//首先打印负号
n*=-1;//取反后当做正数处理
}
if(n==1)
{
printf("1\n");
continue;
}
y=1;
cnt=0;
memset(flag,0,sizeof(flag));//初始化为0
flag[1]=1;
while(y)
{
y*=10;
f[cnt++]=y/n;
y%=n;
if(flag[y])//如果使用过,说明出现循环数节
break;
flag[y]=1;//记录余数是否使用过
}
printf("0.");
for(i=0; i<cnt; i++)
printf("%d",f[i]);
printf("\n");
}
return 0;
}