Hdu2039 三角形

时间:2023-03-08 19:37:35
Hdu2039 三角形

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2039

三角形

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 131836    Accepted Submission(s): 42330

Problem Description
给定三条边,请你判断一下能不能组成一个三角形。
Input
输入数据第一行包含一个数M,接下有M行,每行一个实例,包含三个正数A,B,C。其中A,B,C <1000;
Output
对于每个测试实例,如果三条边长A,B,C能组成三角形的话,输出YES,否则NO。
Sample Input
2
1 2 3
2 2 2
Sample Output
NO
YES
需要用double 不能用int
 #include <iostream>
#include <algorithm>
using namespace std;
int n;
double x,y,z;
int main()
{
while(cin>>n){
while(n--){
cin>>x>>y>>z;
if(x&&y&&z&&(x+y>z)&&(x+z>y)&&(y+z>x)) cout<<"YES"<<endl;
else cout<<"NO"<<endl;
}
}
return ;
}